Bug 1006518 - Unable to launch an instance
Unable to launch an instance
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-nova (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Xavier Queralt
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 14:21 EDT by mlessard
Modified: 2015-06-04 17:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 09:44:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
packstack logs (26.95 KB, application/x-bzip)
2013-09-12 08:08 EDT, mlessard
no flags Details

  None (edit)
Description mlessard 2013-09-10 14:21:45 EDT
Description of problem:
When i try to lunch an instance, the nova scheduler goes into an infinite loop.

Version-Release number of selected component (if applicable):
Havana 
 
Additional info:
The error seems to come from this event, taken from the schduler log fil : 
TRACE nova.openstack.common.periodic_task OperationalError: (OperationalError) (1045, "Access denied for user 'nova'@'192.168.10.130' (using password: YES)") None None

So, the setup of the nova password during the installation must be wrong.
Comment 1 Xavier Queralt 2013-09-11 04:20:54 EDT
It looks like a configuration problem so the problem would be in packstack (if you installed with packstack).

Could you give some more details about the system (f19, rhel, centos, ...) where you had this problem?

Did you deploy using packstack? If so, how many times and how did you run it? When you run it for a second time you must use the answer file generated by the first install, so it gets the passwords properly.

If you deployed using packstack, could you provide the logs which are under /var/tmp/packstack ?
Comment 2 mlessard 2013-09-11 09:06:43 EDT
It the allinone packstack installation on RHEL 6.4. I had to relaunch the installation few times, and i didn't use the answer file after.  

I'm unable to launch an instance via Horizon. 

I am on the road for the day, will provide you the log file tomorrow.
Comment 3 Binoy Arnold 2013-09-12 06:04:42 EDT
I too facing same issue

"Error: An error occurred. Please try again later. "

Created network, uploaded an image (using https://bugzilla.redhat.com/show_bug.cgi?id=1006452)

But not able to create any instance.

Please help
Arnold
Comment 4 mlessard 2013-09-12 08:08:05 EDT
Created attachment 796819 [details]
packstack logs
Comment 5 mlessard 2013-09-12 08:26:58 EDT
Logs uploaded ... In the mean time, if you have any idea on how i can fix the nova password (which password should i put?), let me know.
Comment 6 Xavier Queralt 2014-03-10 09:44:15 EDT
I'm closing this as I don't see any way to further debug the problem. From the previous logs it appears that there was a misconfiguration, probably caused by packstack having been run several times without the same answers file.

Note You need to log in before you can comment on or make changes to this bug.