Bug 100660 - Anaconda Initial GRUB config does not boot, may be filesystem related
Anaconda Initial GRUB config does not boot, may be filesystem related
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
beta1
athlon Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-23 23:32 EDT by Justin Churchey
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-01 18:27:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Churchey 2003-07-23 23:32:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011022
Netscape6/6.2

Description of problem:
After running the initial anaconda installation a reboot resulted in the following:

GRUB Error Code 17

Apparently it is having trouble mounting a partition.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Run through anaconda and install the system
2.Reboot the machine when installation is finished.
3.Let it boot.
    

Actual Results:  You get the GRUB Error Code 17

Expected Results:  Bring up splash screen to boot one of the Red Hat Linux Beta
kernels.

Additional info:
Comment 1 Justin Churchey 2003-07-25 21:17:16 EDT
Actually got the splash screen to come up.  I installed GRUB to the MBR rather
than the first sector of the boot partition, which is what I usually do because
I have a Windows NT-based OS on the same HD, and that is what is recommended by
anaconda.
Comment 2 Michael Fulbright 2003-07-29 12:25:50 EDT
So I understand - everything works fine if you install GRUB to the MBR?
Comment 3 Justin Churchey 2003-08-01 00:46:21 EDT
Yes, the problem appears to happen when GRUB is installed to the first sector of
the /boot partition, but it works fine when installed to the MBR.
Comment 4 Jeremy Katz 2003-10-21 19:14:17 EDT
Does this still happen with test3?

Note You need to log in before you can comment on or make changes to this bug.