Bug 100670 - vi crash with LANG=fr_FR.UTF8
vi crash with LANG=fr_FR.UTF8
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: vim (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-24 03:09 EDT by Féliciano Matias
Modified: 2007-04-18 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 11:42:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (46.27 KB, text/plain)
2003-07-24 09:46 EDT, Féliciano Matias
no flags Details
strace vi /var/log/message (19.14 KB, text/plain)
2003-07-24 09:48 EDT, Féliciano Matias
no flags Details
ltrace vi /var/log/messages (the last 150 lines) (18.89 KB, text/plain)
2003-07-24 09:53 EDT, Féliciano Matias
no flags Details

  None (edit)
Description Féliciano Matias 2003-07-24 03:09:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
vi (/bin/vi from vim-minimal) segfault with LANG=fr_FR.UTF8.

Version-Release number of selected component (if applicable):
6.2.18-2

How reproducible:
Always

Steps to Reproduce:
1. set LANG to fr_FR.UTF8
2. Open a file (for example /root/install.log)
3. scroll in the file with <ctrl>-D and <ctrl>-U
    

Actual Results:  Segfault
Vim: Caught deadly signal SEGV
Vim: Finished.
Erreur de segmentation

Expected Results:  No segmentation fault.

Additional info:
Platform is set to i386 but i use an athlon.
Comment 1 Karsten Hopp 2003-07-24 08:34:37 EDT
I cannot reproduce it here on a freshly installed Beta1 with random scrolling in 
the install.log file. Do you have a another reproducable way to make vi segfault? 
Comment 2 Féliciano Matias 2003-07-24 09:46:15 EDT
Created attachment 93104 [details]
/var/log/messages
Comment 3 Féliciano Matias 2003-07-24 09:48:39 EDT
Created attachment 93105 [details]
strace vi /var/log/message
Comment 4 Féliciano Matias 2003-07-24 09:53:35 EDT
Created attachment 93106 [details]
ltrace vi /var/log/messages  (the last 150 lines)
Comment 5 Féliciano Matias 2003-07-24 09:59:02 EDT
> Do you have a another reproducable way to make vi segfault?

easy :
# echo $LANG
fr_FR.UTF-8  <== UTF-8 and not UTF8. vi also crash with UTF8.
# vi /var/log/messages 
Vim: Caught deadly signal SEGV
Vim: Finished.
Erreur de segmentation

Instant segfault :-)

# env LANG=C vi /var/log/message
OK

I do this with RH9 and a "chroot /mnt/severn". I can do a test under severn in
one hour.

Have you a "alias vi=vim" ?
Comment 6 Féliciano Matias 2003-07-24 10:27:03 EDT
Sorry i can reproduce under severn.
But this bug append in rescue mode (CD1 severn)!

I do a "rpm -V -a" and everything seems fine.
Comment 7 Karsten Hopp 2003-07-24 10:35:24 EDT
I got the segfault now, too and will send a detailled bugreport to the vim maintainers in a few 
minutes. 
Comment 8 Féliciano Matias 2003-07-24 10:48:05 EDT
> i can reproduce under severn.

I can *NOT* reproduce under severn (i have a very poor english :-)).

in rescue mode, i do a "chroot /mnt/sysimage".
Comment 9 Peter van Egdom 2003-07-27 13:45:14 EDT
I experience this bug too. As root, doing "vi /root/install.log" results in:
  
  Vim: Caught deadly signal SEGV
  Vim: Finished.
  Segmentatie fout

100% reproducable with :
"vim-6.2.18-2" (Severn)
"vim-6.2.21-2" (Raw Hide)

I also experience it with a normal user account when editing in some text files.
Comment 10 Aleksey Nogin 2003-07-28 19:08:20 EDT
I see this too, with ru_RU.UTF-8.
Comment 11 Karsten Hopp 2003-07-29 08:14:58 EDT
vim-6.2.57 should fix this, please verify with the packages from 
http://people.redhat.com/karsten/ 
Comment 12 Peter van Egdom 2003-07-29 12:30:24 EDT
For me, the described problems seem fixed with package vim-6.2.57-1.
Comment 13 Aleksey Nogin 2003-07-29 16:33:10 EDT
Fixed my problems too.
Comment 14 Féliciano Matias 2003-07-30 13:47:32 EDT
work to me.
Comment 15 Dave Habben 2003-10-22 10:56:31 EDT
Can this be marked as RAWHIDE/CLOSED?

The current version in rawhide is:
$ rpm -q vim-minimal
vim-minimal-6.2.121-1
Comment 16 Karsten Hopp 2003-10-22 11:42:25 EDT
yes, I think so. The latest reports indicate that this has been fixed. 

Note You need to log in before you can comment on or make changes to this bug.