Bug 1006755 - kie-nio2-jgit depends on a timestamped snapshot version of org.eclipse.jgit
kie-nio2-jgit depends on a timestamped snapshot version of org.eclipse.jgit
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexandre Porcelli
Lukáš Petrovický
:
Depends On:
Blocks: 989519
  Show dependency treegraph
 
Reported: 2013-09-11 04:58 EDT by Geoffrey De Smet
Modified: 2013-09-26 03:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 05:24:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoffrey De Smet 2013-09-11 04:58:33 EDT
The version of jgit is a timestamped snapshot:

      <version.org.eclipse.jgit>2.1.0.201209190230-r</version.org.eclipse.jgit>

      <dependency>
        <groupId>org.eclipse.jgit</groupId>
        <artifactId>org.eclipse.jgit</artifactId>
        <version>${version.org.eclipse.jgit}</version>
      </dependency>

We can't release a Final with a timestamped snapshot, because it blocks testing (see BZ-991777 for another example).
Comment 2 Geoffrey De Smet 2013-09-11 05:05:02 EDT
@Ryan Zhang: I am beginning to doubt that this is indeed a timestamped snapshot. It looks like a valid, normal release of jgit:
  https://repository.jboss.org/nexus/index.html#nexus-search;gav~org.eclipse.jgit~org.eclipse.jgit~~~~kw,versionexpand
jgit just uses weird version numbering.

Note You need to log in before you can comment on or make changes to this bug.