Bug 989519 - BOM to centralize dependency management of the jboss integration platform (jboss-integration-platform-bom)
BOM to centralize dependency management of the jboss integration platform (jb...
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Build and Assembly (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: 6.0.0
Assigned To: Geoffrey De Smet
Lukáš Petrovický
:
Depends On: 996210 991777 993565 995133 995522 996028 996630 996966 997147 999072 1004177 1006755
Blocks: 996320
  Show dependency treegraph
 
Reported: 2013-07-29 08:28 EDT by Geoffrey De Smet
Modified: 2014-08-06 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoffrey De Smet 2013-07-29 08:28:48 EDT
As discussed here:
  http://pad.engineering.redhat.com/Q5TlS74nyQ
Comment 2 Geoffrey De Smet 2013-08-02 05:39:04 EDT
User facing boms were created on master and 6.0.x (multiple commits - too many to mention here)
Comment 3 Geoffrey De Smet 2013-08-05 10:32:46 EDT
Version properties in the parent pom have been updated to the EAP pattern "version.{groupId}"
http://github.com/droolsjbpm/droolsjbpm-build-bootstrap/compare/cc2b9b7...68e0dd7
Comment 4 Geoffrey De Smet 2013-08-06 05:48:25 EDT
Blocked by
https://bugzilla.redhat.com/show_bug.cgi?id=993565
Comment 5 Geoffrey De Smet 2013-08-07 08:32:33 EDT
Designer fixed. Found similar trouble in droolsjbpm-integration.
Comment 6 Geoffrey De Smet 2013-08-12 10:17:46 EDT
First set of version that are not in sync between switchyard and droolsjbpm.

Droolsjbpm needs to upgrade
- batik from 1.6.-1 to 1.7
- commons-httpclient from 3.1 to 4.2.1
- commons-net from 2.0 to 2.2
- ftpserver-core from 1.0.4 to 1.0.6
- netty from 3.2.0.Final to 3.2.6.Final
- quartz from 1.6.1 to 1.8.5
- spring from 3.0.6.RELEASE to 3.0.7.RELEASE

SwitchYard needs to upgrade
- camel from 2.10.0 to 2.10.3
- cxf from 2.6.1 to 2.6.6
- hornetq from 2.3.0.CR1 to 2.3.1.Final
- ironjacamar from 1.0.15.Final to 1.0.17.Final
- jettison from 1.2 to 1.3.1
- junit from 4.10 to 4.11
- slf4j from 1.6.4 to 1.7.2
- weld from 1.1.10.Final to 1.1.13.Final
- xmlunit from 1.1 to 1.3


Probably:
- droolsjbpm and switchyard will probably need to upgrade antlr from 3.3 to 3.5.

Under investigation:
- SwitchYard uses deltaspike already. Drools still uses Seam 3 and Solder.
- SwitchYard uses maven-plugin 3.1. Drools uses 3.0.5 to be compatible with maven 3.0.
- SY uses xalan 2.7.1-1.jbossorg. Drools uses xalan 2.7.1.
Comment 7 Geoffrey De Smet 2013-08-13 10:47:56 EDT
Upgraded: commons-net, ftpserver-core, netty, quartz, spring
Not needed to be upgraded: commons-httpclient 3 (because httpcomponents client 4 uses different GAV's and java packages)
Still todo for droolsjbpm: batik, see https://bugzilla.redhat.com/show_bug.cgi?id=996210
Comment 8 Geoffrey De Smet 2013-08-23 12:56:59 EDT
Done on droolsjbpm master and 6.0.x

Here's the location of the new bom:
  https://github.com/jboss-integration/jboss-integration-platform-bom
Comment 12 Lukáš Petrovický 2013-10-17 02:35:09 EDT
The BOM is in place, the test suite now uses it also. VERIFIED with ER4.

Note You need to log in before you can comment on or make changes to this bug.