Bug 1006766 - Missing keys in horizon's configuration
Missing keys in horizon's configuration
Status: CLOSED DUPLICATE of bug 988316
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: RHOS Maint
Nir Magnezi
: Reopened
: 1006799 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 05:09 EDT by Xavier Queralt
Modified: 2014-06-18 03:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 09:46:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1223317 None None None Never

  None (edit)
Description Xavier Queralt 2013-09-11 05:09:01 EDT
Description of problem:

Horizon puppet module has an outdated local_settings template and lacks some keys needed in the havana release. The template should be sync with https://github.com/openstack/horizon/blob/master/openstack_dashboard/local/local_settings.py.example

Version-Release number of selected component (if applicable):

openstack-packstack-2013.2.1-0.9.dev756.fc20.noarch
python-django-horizon-2013.2-0.10b3.fc20.noarch
openstack-dashboard-2013.2-0.10b3.fc20.noarch

How reproducible:
always

Steps to Reproduce:
1. When using f19 and django >= 1.5 the value ALLOWED_HOSTS must contain the hostname/ip where we're deploying or it will forbid any request.
2. If OPENSTACK_IMAGE_BACKEND is not provided, the list of image types when creating a new image will be empty
3. There might be other needed values which I'm missing right now.

Actual results:


Expected results:


Additional info:
Comment 1 Xavier Queralt 2013-09-11 06:13:04 EDT
*** Bug 1006799 has been marked as a duplicate of this bug. ***
Comment 2 Sandro Mathys 2013-09-13 09:28:39 EDT
FYI: OPENSTACK_IMAGE_BACKEND now has a sane default in upstream Horizon (will be included in Havana rc1), therefore local_settings does not need to provide it anymore.

*** This bug has been marked as a duplicate of bug 988316 ***
Comment 3 Xavier Queralt 2013-09-13 09:39:18 EDT
Even thought horizon has a sane default, packstack should provide a proper local_settings which should be in sync with the one provided upstream.

For example, keys like ALLOWED_HOSTS are not handled yet

Reopening this bug because it is for getting the new template into packstack.
Comment 4 Xavier Queralt 2013-09-13 09:46:01 EDT
Oops, you were right about the duplicate. I jumped to a wrong tab and mistook one bz for another.

*** This bug has been marked as a duplicate of bug 988316 ***

Note You need to log in before you can comment on or make changes to this bug.