Bug 1007077 - TypeError: 'NoneType' object is not callable
TypeError: 'NoneType' object is not callable
Status: CLOSED DUPLICATE of bug 1005685
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:e3d397e10ba979c249fa0f0abbc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 17:14 EDT by Shawn Starr
Modified: 2013-09-11 17:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 17:31:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (718.25 KB, text/plain)
2013-09-11 17:14 EDT, Shawn Starr
no flags Details
File: anaconda.log (7.82 KB, text/plain)
2013-09-11 17:14 EDT, Shawn Starr
no flags Details
File: environ (491 bytes, text/plain)
2013-09-11 17:14 EDT, Shawn Starr
no flags Details
File: lsblk_output (1.15 KB, text/plain)
2013-09-11 17:14 EDT, Shawn Starr
no flags Details
File: nmcli_dev_list (4.42 KB, text/plain)
2013-09-11 17:14 EDT, Shawn Starr
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-11 17:14 EDT, Shawn Starr
no flags Details
File: program.log (26.38 KB, text/plain)
2013-09-11 17:15 EDT, Shawn Starr
no flags Details
File: storage.log (43.09 KB, text/plain)
2013-09-11 17:15 EDT, Shawn Starr
no flags Details
File: syslog (60.69 KB, text/plain)
2013-09-11 17:15 EDT, Shawn Starr
no flags Details
File: ifcfg.log (479 bytes, text/plain)
2013-09-11 17:15 EDT, Shawn Starr
no flags Details
File: packaging.log (1.03 MB, application/octet-stream)
2013-09-11 17:15 EDT, Shawn Starr
no flags Details

  None (edit)
Description Shawn Starr 2013-09-11 17:14:30 EDT
Description of problem:
1) PXE boot Fedora 20-Alpha-RC1, no kickstart used
1) Chose locale: English-Canada
2) Changed timezone to Toronto
3) Tried to use dl.fedoraproject.org stage mirror for the repository
4) Chose the group 'KDE Plasma Workspaces' then clicked Done, Anaconda crashed then.

Version-Release number of selected component:
anaconda-20.14-1

The following was filed automatically by anaconda:
anaconda 20.14-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/copy.py", line 88, in copy
    rv = reductor(2)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 306, in _method_changed
    old_source = copy.copy(self.data.method)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 467, in changed
    method_changed = self._method_changed()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 127, in _runSpoke
    if action.changed and (not action.skipTo or (action.skipTo and action.applyOnSkip)):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 413, in _on_spoke_clicked
    self._runSpoke(spoke)
TypeError: 'NoneType' object is not callable

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd-x86_64.img ip=dhcp inst.stage2=ftp://172.18.2.4/os-x86_64 slub_debug=- geoloc=0 BOOT_IMAGE=vmlinuz-x86_64 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha
Comment 1 Shawn Starr 2013-09-11 17:14:38 EDT
Created attachment 796521 [details]
File: anaconda-tb
Comment 2 Shawn Starr 2013-09-11 17:14:42 EDT
Created attachment 796522 [details]
File: anaconda.log
Comment 3 Shawn Starr 2013-09-11 17:14:46 EDT
Created attachment 796523 [details]
File: environ
Comment 4 Shawn Starr 2013-09-11 17:14:49 EDT
Created attachment 796524 [details]
File: lsblk_output
Comment 5 Shawn Starr 2013-09-11 17:14:53 EDT
Created attachment 796525 [details]
File: nmcli_dev_list
Comment 6 Shawn Starr 2013-09-11 17:14:56 EDT
Created attachment 796526 [details]
File: os_info
Comment 7 Shawn Starr 2013-09-11 17:15:03 EDT
Created attachment 796527 [details]
File: program.log
Comment 8 Shawn Starr 2013-09-11 17:15:07 EDT
Created attachment 796528 [details]
File: storage.log
Comment 9 Shawn Starr 2013-09-11 17:15:11 EDT
Created attachment 796529 [details]
File: syslog
Comment 10 Shawn Starr 2013-09-11 17:15:15 EDT
Created attachment 796530 [details]
File: ifcfg.log
Comment 11 Shawn Starr 2013-09-11 17:15:24 EDT
Created attachment 796531 [details]
File: packaging.log
Comment 12 David Shea 2013-09-11 17:31:21 EDT

*** This bug has been marked as a duplicate of bug 1005685 ***

Note You need to log in before you can comment on or make changes to this bug.