This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 1005685 - setting repo source to URL gives "TypeError: 'NoneType' object is not callable"
setting repo source to URL gives "TypeError: 'NoneType' object is not callable"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
20
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:e3d397e10ba979c249fa0f0abbc...
: Reopened
: 1007077 (view as bug list)
Depends On:
Blocks: F20AlphaFreezeException
  Show dependency treegraph
 
Reported: 2013-09-09 03:34 EDT by Jens Petersen
Modified: 2013-09-17 22:20 EDT (History)
10 users (show)

See Also:
Fixed In Version: pykickstart-1.99.39-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 22:20:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (329.66 KB, text/plain)
2013-09-09 03:34 EDT, Jens Petersen
no flags Details
File: anaconda.log (6.60 KB, text/plain)
2013-09-09 03:34 EDT, Jens Petersen
no flags Details
File: environ (441 bytes, text/plain)
2013-09-09 03:34 EDT, Jens Petersen
no flags Details
File: lsblk_output (1.38 KB, text/plain)
2013-09-09 03:34 EDT, Jens Petersen
no flags Details
File: nmcli_dev_list (4.35 KB, text/plain)
2013-09-09 03:35 EDT, Jens Petersen
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-09 03:35 EDT, Jens Petersen
no flags Details
File: program.log (36.17 KB, text/plain)
2013-09-09 03:35 EDT, Jens Petersen
no flags Details
File: storage.log (65.87 KB, text/plain)
2013-09-09 03:35 EDT, Jens Petersen
no flags Details
File: syslog (63.11 KB, text/plain)
2013-09-09 03:35 EDT, Jens Petersen
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-09-09 03:35 EDT, Jens Petersen
no flags Details
File: packaging.log (26.87 KB, text/plain)
2013-09-09 03:35 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2013-09-09 03:34:36 EDT
Description of problem:
I tried to set a repo url

Version-Release number of selected component:
anaconda-20.12-1

The following was filed automatically by anaconda:
anaconda 20.12-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/copy.py", line 88, in copy
    rv = reductor(2)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 306, in _method_changed
    old_source = copy.copy(self.data.method)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 467, in changed
    method_changed = self._method_changed()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 127, in _runSpoke
    if action.changed and (not action.skipTo or (action.skipTo and action.applyOnSkip)):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 413, in _on_spoke_clicked
    self._runSpoke(spoke)
TypeError: 'NoneType' object is not callable

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC5\x20x86_64 quiet askmethod BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Alpha-TC5
Comment 1 Jens Petersen 2013-09-09 03:34:43 EDT
Created attachment 795510 [details]
File: anaconda-tb
Comment 2 Jens Petersen 2013-09-09 03:34:48 EDT
Created attachment 795511 [details]
File: anaconda.log
Comment 3 Jens Petersen 2013-09-09 03:34:52 EDT
Created attachment 795512 [details]
File: environ
Comment 4 Jens Petersen 2013-09-09 03:34:56 EDT
Created attachment 795513 [details]
File: lsblk_output
Comment 5 Jens Petersen 2013-09-09 03:35:01 EDT
Created attachment 795514 [details]
File: nmcli_dev_list
Comment 6 Jens Petersen 2013-09-09 03:35:05 EDT
Created attachment 795515 [details]
File: os_info
Comment 7 Jens Petersen 2013-09-09 03:35:10 EDT
Created attachment 795516 [details]
File: program.log
Comment 8 Jens Petersen 2013-09-09 03:35:15 EDT
Created attachment 795517 [details]
File: storage.log
Comment 9 Jens Petersen 2013-09-09 03:35:20 EDT
Created attachment 795518 [details]
File: syslog
Comment 10 Jens Petersen 2013-09-09 03:35:26 EDT
Created attachment 795519 [details]
File: ifcfg.log
Comment 11 Jens Petersen 2013-09-09 03:35:32 EDT
Created attachment 795520 [details]
File: packaging.log
Comment 12 Jens Petersen 2013-09-09 03:40:05 EDT
Used askmethod and tried to set download URL - this time a correct url I think.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC5\x20x86_64 quiet askmethod BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.12-1
product:        Fedora
reason:         TypeError: 'NoneType' object is not callable
release:        Cannot get release name.
version:        20-Alpha-TC5
Comment 13 David Shea 2013-09-11 17:31:21 EDT
*** Bug 1007077 has been marked as a duplicate of this bug. ***
Comment 14 Jens Petersen 2013-09-11 21:29:40 EDT
I still see this backtracing with F20 Alpha RC1.

Let's leave this open at least until it is pushed to stable.
Comment 15 Jens Petersen 2013-09-11 21:33:59 EDT
I think pykickstart-1.99.39-1.fc20 needs to be pushed to Bodhi for testing.
Comment 16 Jens Petersen 2013-09-13 07:54:08 EDT
Thanks - looks fixed to me with Alpha RC2.
Comment 17 Fedora Update System 2013-09-13 08:22:56 EDT
pykickstart-1.99.39-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-16565/pykickstart-1.99.39-1.fc20
Comment 18 Fedora Update System 2013-09-17 22:20:10 EDT
pykickstart-1.99.39-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.