Bug 1007094 - AttributeError: 'NoneType' object has no attribute 'id'
AttributeError: 'NoneType' object has no attribute 'id'
Status: CLOSED DUPLICATE of bug 1004572
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:1d0a74e41efd1b3b69a2fd46b0a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 18:06 EDT by Flóki Pálsson
Modified: 2013-09-12 10:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-12 10:17:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (820.15 KB, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details
File: anaconda.log (16.71 KB, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details
File: environ (441 bytes, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details
File: lsblk_output (5.81 KB, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details
File: nmcli_dev_list (4.23 KB, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details
File: program.log (132.31 KB, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details
File: storage.log (550.79 KB, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details
File: ifcfg.log (564 bytes, text/plain)
2013-09-11 18:06 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Flóki Pálsson 2013-09-11 18:06:13 EDT
Description of problem:
Selecting etc4 /dev/sc14 as disk and not formating.

Version-Release number of selected component:
anaconda-20.14-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.14-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1948, in copy
    root.swaps = [new.devicetree.getDeviceByID(d.id) for d in root.swaps]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 845, in _reset_storage
    self.__storage = self.storage.copy()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 866, in refresh
    self._reset_storage()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 108, in _runSpoke
    action.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 413, in _on_spoke_clicked
    self._runSpoke(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 429, in _on_spoke_clicked
    self._on_spoke_clicked(self._spokes[dest].selector, None, self._spokes[dest])
AttributeError: 'NoneType' object has no attribute 'id'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang is_IS.utf8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-20-Al rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
other involved packages: python-blivet-0.20-1.fc20.noarch
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20
Comment 1 Flóki Pálsson 2013-09-11 18:06:22 EDT
Created attachment 796543 [details]
File: anaconda-tb
Comment 2 Flóki Pálsson 2013-09-11 18:06:26 EDT
Created attachment 796544 [details]
File: anaconda.log
Comment 3 Flóki Pálsson 2013-09-11 18:06:30 EDT
Created attachment 796545 [details]
File: environ
Comment 4 Flóki Pálsson 2013-09-11 18:06:36 EDT
Created attachment 796546 [details]
File: lsblk_output
Comment 5 Flóki Pálsson 2013-09-11 18:06:40 EDT
Created attachment 796547 [details]
File: nmcli_dev_list
Comment 6 Flóki Pálsson 2013-09-11 18:06:44 EDT
Created attachment 796548 [details]
File: os_info
Comment 7 Flóki Pálsson 2013-09-11 18:06:48 EDT
Created attachment 796549 [details]
File: program.log
Comment 8 Flóki Pálsson 2013-09-11 18:06:54 EDT
Created attachment 796550 [details]
File: storage.log
Comment 9 Flóki Pálsson 2013-09-11 18:06:57 EDT
Created attachment 796551 [details]
File: ifcfg.log
Comment 10 David Shea 2013-09-12 10:17:31 EDT

*** This bug has been marked as a duplicate of bug 1004572 ***

Note You need to log in before you can comment on or make changes to this bug.