Bug 1004572 - AttributeError: 'NoneType' object has no attribute 'id'
AttributeError: 'NoneType' object has no attribute 'id'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:819710cc56fe7dfc6855555006d...
: CommonBugs
: 1004846 1007094 1010441 1011423 1011598 1015817 1034997 (view as bug list)
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-09-04 21:05 EDT by Amit Saha
Modified: 2015-07-26 18:15 EDT (History)
23 users (show)

See Also:
Fixed In Version: python-blivet-0.22-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-26 02:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (47.04 KB, text/plain)
2013-09-04 21:05 EDT, Amit Saha
no flags Details
File: environ (536 bytes, text/plain)
2013-09-04 21:05 EDT, Amit Saha
no flags Details
File: lsblk_output (3.90 KB, text/plain)
2013-09-04 21:05 EDT, Amit Saha
no flags Details
File: messages (411.97 KB, text/plain)
2013-09-04 21:05 EDT, Amit Saha
no flags Details
File: nmcli_dev_list (6.70 KB, text/plain)
2013-09-04 21:06 EDT, Amit Saha
no flags Details
File: os_info (281 bytes, text/plain)
2013-09-04 21:06 EDT, Amit Saha
no flags Details
File: program.log (89.73 KB, text/plain)
2013-09-04 21:06 EDT, Amit Saha
no flags Details
File: storage.log (599.31 KB, text/plain)
2013-09-04 21:06 EDT, Amit Saha
no flags Details
File: ifcfg.log (2.75 KB, text/plain)
2013-09-04 21:06 EDT, Amit Saha
no flags Details
File: anaconda-tb (1.25 MB, application/octet-stream)
2013-09-04 21:06 EDT, Amit Saha
no flags Details
anaconda-tb for Comment 11 (1.08 MB, text/plain)
2013-09-05 13:30 EDT, Steve Tyler
no flags Details

  None (edit)
Description Amit Saha 2013-09-04 21:05:36 EDT
Description of problem:
I ran into this while rying to customize the automatic partitioning scheme that Anaconda selected for me. I am using Fedora 20 Scientific Spin Test Compose 3 (x86-64). 

Version-Release number of selected component:
anaconda-20.10-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1948, in copy
    root.swaps = [new.devicetree.getDeviceByID(d.id) for d in root.swaps]
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 767, in _save_devicetree
    _blivet_copy = self.storage.copy()
  File "/usr/lib/python2.7/site-packages/blivet/devicefactory.py", line 704, in configure
    self._save_devicetree()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1924, in factoryDevice
    factory.configure()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1069, in _replace_device
    new_device = self.__storage.factoryDevice(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1360, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2398, in _save_current_selector
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2409, in on_selector_clicked
    self._save_current_selector()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 216, in _onSelectorClicked
    cb(selector)
AttributeError: 'NoneType' object has no attribute 'id'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Scientific-KDE-x86_6 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
other involved packages: python-blivet-0.20-1.fc20.noarch
product:        Fedora
release:        Fedora release 20 (Null)
type:           anaconda
version:        20
Comment 1 Amit Saha 2013-09-04 21:05:42 EDT
Created attachment 793915 [details]
File: anaconda.log
Comment 2 Amit Saha 2013-09-04 21:05:46 EDT
Created attachment 793916 [details]
File: environ
Comment 3 Amit Saha 2013-09-04 21:05:50 EDT
Created attachment 793917 [details]
File: lsblk_output
Comment 4 Amit Saha 2013-09-04 21:05:58 EDT
Created attachment 793918 [details]
File: messages
Comment 5 Amit Saha 2013-09-04 21:06:02 EDT
Created attachment 793919 [details]
File: nmcli_dev_list
Comment 6 Amit Saha 2013-09-04 21:06:07 EDT
Created attachment 793920 [details]
File: os_info
Comment 7 Amit Saha 2013-09-04 21:06:12 EDT
Created attachment 793921 [details]
File: program.log
Comment 8 Amit Saha 2013-09-04 21:06:21 EDT
Created attachment 793922 [details]
File: storage.log
Comment 9 Amit Saha 2013-09-04 21:06:26 EDT
Created attachment 793923 [details]
File: ifcfg.log
Comment 10 Amit Saha 2013-09-04 21:06:39 EDT
Created attachment 793924 [details]
File: anaconda-tb
Comment 11 Steve Tyler 2013-09-05 13:19:33 EDT
Attempt to encrypt all partitions and logical volumes.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-3.fc20.x86_64
package:        anaconda-20.10-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha-TC4
Comment 12 Steve Tyler 2013-09-05 13:30:56 EDT
Created attachment 794389 [details]
anaconda-tb for Comment 11
Comment 13 Steve Tyler 2013-09-05 13:34:24 EDT
Comment on attachment 794389 [details]
anaconda-tb for Comment 11

Tested with:
$ qemu-kvm -m 4096 -hda f20-test-3.img -cdrom ~/xfr/fedora/F20/Alpha/Fedora-20-Alpha-TC4-x86_64-DVD.iso -vga std -boot menu=on
Comment 14 Fedora Update System 2013-09-06 17:48:01 EDT
python-blivet-0.22-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-blivet-0.22-1.fc20
Comment 15 Fedora Update System 2013-09-07 13:04:13 EDT
Package python-blivet-0.22-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.22-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16042/python-blivet-0.22-1.fc20
then log in and leave karma (feedback).
Comment 16 David Lehman 2013-09-10 16:07:33 EDT
*** Bug 1004846 has been marked as a duplicate of this bug. ***
Comment 17 stan 2013-09-11 15:00:11 EDT
Custom partition, re-use existing ext4 partition as root.  Delay, then error comes up.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.14-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha
Comment 18 stan 2013-09-11 15:16:13 EDT
Looks like the python-blivet fix wasn't what was needed for this.  If it was in the Alpha candidate.  I would hope that each new test candidate would pull in all the updates in updates-testing before being created.  That's the point of having tests, right?  Can someone confirm?

So, same behavior as TC5.  Failed when creating the root partition from an existing ext4 partition when in the manual partition screen.  It failed once when selecting a /boot partition also.

The behavior is strange.  I select an existing partition, then click +.  The popup to create a mount point comes up, I select the mount point, leave the size blank as recommended, and click create mount point.  Up comes the information in the upper right hand corner, but nothing shows up under F20 in the upper left, and the mount point isn't filled in on the upper right.  And the selection popup becomes part of the page under the information in the upper right.  But it won't let me select a new partition.

Sometimes it will let me fill in the mount point on the upper right, sometimes not.  Because I read that anaconda now requires formatting on the root partition, I selected that, and after a delay, the display refreshed with the box checked.  But then everything was frozen except the mouse.  Eventually, the error showed up.
Comment 19 David Lehman 2013-09-11 15:50:59 EDT
I suspect you don't have python-blivet-0.22-1, which is what you need to get the fix.

FWIW anaconda has required creating a new root filesystem for several years now.
Comment 20 stan 2013-09-11 16:10:22 EDT
I always re-format anyway, so I wouldn't have noticed.  I just mentioned it for completeness of the description.  In case it mattered to the error.

Obviously it doesn't if I was using the broken version of the program that is causing the error.  :-)
Comment 21 Clyde E. Kunkel 2013-09-11 23:14:53 EDT
Come on guys!  Still?  All I am trying to do is what worked flawlesslly in 19:  select a single disk, btrfs fs, custom paritioning.  Click +, select / and request 50GB.  Errors out every time.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 selinux=0 BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.14-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha
Comment 22 David Shea 2013-09-12 10:17:31 EDT
*** Bug 1007094 has been marked as a duplicate of this bug. ***
Comment 23 stan 2013-09-12 14:40:55 EDT
Assigning / to existing ext4 partition in custom partitioning.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.15-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha
Comment 24 Clyde E. Kunkel 2013-09-12 14:55:39 EDT
same ol' same ol'.  Tried to create btrfs / on empty (except for bios-boot partition) disk.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 selinux=0 BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.15-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha
Comment 25 stan 2013-09-12 15:08:32 EDT
This was with Alpha TC2.  The file size was the same as Alpha TC1, but the checksum was different (Alpha TC1 failed), so I assume I was using the right file.

Anyhow, still has the error.  Not sure if this image had python-blivet-0.22-1 in it.  Probably not, given the result.  Is there a time frame for when that version will go into the images?  After release?  i.e.  is the image now frozen until after release?  But the iso images don't change after release, do they?  F21?
Comment 26 Clyde E. Kunkel 2013-09-16 12:23:30 EDT
confirm fixed using live cd from 20130914 updated with python-blivet-0.22-1.fc20.noarch, anaconda-20.16-1.fc20.x86_64. Other probs tho; off to search for bzs.
Comment 27 stan 2013-09-17 13:51:25 EDT
I looked at the pull request for Alpha RC3 and didn't see python-blivet-0.22-1 mentioned at all, though anaconda is up to 20.17-1.  Before I download and try, can someone confirm whether the fix for this bug is in the new Alpha RC3.  Thanks.
Comment 28 Clyde E. Kunkel 2013-09-20 13:44:13 EDT
Just testing on the off-chance python-blivert-0.22-1 had been included.  One wonders why a fix is not included when the fix has been shown to fix a problem.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=a9901eab-13b6-4f9d-8a40-991dd02acaa2 selinux=0 BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha
Comment 29 David Lehman 2013-09-20 15:26:38 EDT
*** Bug 1010441 has been marked as a duplicate of this bug. ***
Comment 30 Adam Williamson 2013-09-24 06:43:27 EDT
"One wonders why a fix is not included when the fix has been shown to fix a problem."

One could instead just read the policy:

https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process

It is not a hard page to find:

https://fedoraproject.org/wiki/Special:WhatLinksHere/QA:SOP_freeze_exception_bug_process

If anyone had bothered to nominate this as a freeze exception issue it would likely have made Alpha. But no-one did.
Comment 31 David Shea 2013-09-24 08:29:10 EDT
*** Bug 1011423 has been marked as a duplicate of this bug. ***
Comment 32 Clyde E. Kunkel 2013-09-24 11:31:06 EDT
(In reply to Adam Williamson from comment #30)
> "One wonders why a fix is not included when the fix has been shown to fix a
> problem."
> 
> One could instead just read the policy:
> 
> https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process
> 
> It is not a hard page to find:
> 
> https://fedoraproject.org/wiki/Special:WhatLinksHere/QA:
> SOP_freeze_exception_bug_process
> 
> If anyone had bothered to nominate this as a freeze exception issue it would
> likely have made Alpha. But no-one did.


Nice to know.  No need for sarcasm.  Looks like this bz was reviewed after the fix as confirmed by Fedora QA and Anaconda folks who could have just stepped in and pushed the fix.
Comment 33 David Shea 2013-09-24 12:27:52 EDT
*** Bug 1011598 has been marked as a duplicate of this bug. ***
Comment 34 Adam Williamson 2013-09-24 21:05:23 EDT
No sarcasm intended, just explaining the situation.

The intent is that no-one 'just steps in and pushes fixes'. That's the point of having a freeze exception process in the first place: when we just relied on people in the loop exercising 'common sense' in choosing what fixes to push, what we got was a mess with lots of needless breakage. So we came up with a policy and process to deal with it instead, and that's what the FE process is. With a process we can always track precisely what issues we will and will not take fixes for during freezes, and the policy aids us in deciding which fixes we ought to take and which we shouldn't, and doing that consistently and sensibly.

(anaconda doesn't actually obey the alpha freeze entirely, they put non-FE changes into builds during the freeze, which we in QA aren't entirely happy with, but we can see their reason for doing so. but since there was no blocker or FE bug which caused us to pull a new python-blivet into the RC builds, this fix didn't make it.)
Comment 35 Clyde E. Kunkel 2013-09-25 12:07:36 EDT
(In reply to Adam Williamson from comment #34)
> <snip>

Thanks. Makes sense.  I just couldn't understand why the fix wasn't pushed.  There is a workaround if you use one of the nightly live isos and yum update python-blivet and that allowed me to provide positive karma.  I see now that koji msged that python-blivet can be pushed if the maintainer desires.  We'll see what happens.
Comment 36 Mike Ruckman 2013-09-25 13:35:59 EDT
Discussed in 2013-09-25 Blocker Review Meeting [1]. Acknowledged as an AcceptedBlocker - Violates the follwing F20 beta release criterion: "When using the custom partitioning flow, the installer must be able to ... Create mount points backed by ext4 partitions, LVM volumes or btrfs volumes, or software RAID arrays at RAID levels 0, 1 and 5 containing ext4 partitions" [2][3].

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/
[2] https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning
[3] https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Guided_partitioning
Comment 37 John Reiser 2013-09-25 22:16:02 EDT
Custom partitioning, standard partitions, root and swap on sda, omit install of bootloader.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Alpha\x20x86_64  BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.11.0-300.fc20.x86_64
package:        anaconda-20.18-1
product:        Fedora
reason:         AttributeError: 'NoneType' object has no attribute 'id'
release:        Cannot get release name.
version:        20-Alpha
Comment 38 Fedora Update System 2013-09-26 02:19:25 EDT
python-blivet-0.22-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 39 David Lehman 2013-10-17 10:50:46 EDT
*** Bug 1015817 has been marked as a duplicate of this bug. ***
Comment 40 David Shea 2013-11-26 15:22:16 EST
*** Bug 1034997 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.