Bug 1007158 - OVS flow rules should strip vlan for tunnel data
OVS flow rules should strip vlan for tunnel data
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity urgent
: beta
: 4.0
Assigned To: Bob Kukura
Ofer Blaut
: ZStream
Depends On:
Blocks: 1017414
  Show dependency treegraph
 
Reported: 2013-09-11 23:22 EDT by Bob Kukura
Modified: 2016-04-26 23:10 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-openvswitch-2013.2-0.3.2.b3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1017414 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:24:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GRE traffic between hosts (19.29 KB, application/octet-stream)
2013-11-24 01:30 EST, Ofer Blaut
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1224244 None None None Never

  None (edit)
Description Bob Kukura 2013-09-11 23:22:44 EDT
Description of problem:

GRE tunnel payloads in grizzly contain the local VLAN tag used on the sending side's integration bridge. This serves no purpose, wastes bandwidth, exacerbates MTU issues, and slows processing in the kernel. It can easily be addressed by adding a strip_vlan action to the set_tunnel flow rule.

Note that the flow rules have changed substantially in havana, and include the strip_vlan action. Grizzly needs its own fix rather than a back-port from havana.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. configure multi-node setup with GRE tenant networks
2. ping one VM from another on a different node
3. use tcpdump to inspect the GRE packets

Actual results:

The GRE payloads contain unneeded 802.1Q headers.


Expected results:

No 802.1Q header in GRE payloads.


Additional info:
Comment 2 Perry Myers 2013-09-12 10:50:25 EDT
We need to consider this for rhos 3.0.z as well, since current users are hitting these performance issues.  Flagging for 3.0.z
Comment 6 Bob Kukura 2013-11-19 09:56:24 EST
The upstream havana openswitch-agent code has significantly reworked the OVS flow rules, and one result is that the VLAN tags are now stripped from tunnel payloads. This can be verified by looking at the rules with ovs-ofctl or looking at the tunnel traffic with tcpdump.
Comment 7 Ofer Blaut 2013-11-24 01:30:46 EST
Created attachment 828224 [details]
GRE traffic between hosts
Comment 8 Ofer Blaut 2013-11-24 01:32:52 EST
Few weeks ago I have checked  GRE traffic between hosts & router no VLAN have been seen , attached capture
Comment 11 errata-xmlrpc 2013-12-19 19:24:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.