Bug 1017414 - OVS flow rules should strip vlan for tunnel data
OVS flow rules should strip vlan for tunnel data
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-quantum (Show other bugs)
3.0
Unspecified Unspecified
urgent Severity urgent
: async
: 3.0
Assigned To: Bob Kukura
Ofer Blaut
: ZStream
Depends On: 1007158
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-09 16:17 EDT by Chris Pelland
Modified: 2016-04-26 16:39 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1007158
Environment:
Last Closed: 2013-12-02 14:10:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix from upstream (2.27 KB, patch)
2013-10-09 16:49 EDT, Lon Hohberger
no flags Details | Diff
Replacement patch (2.15 KB, patch)
2013-10-10 15:49 EDT, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1224244 None None None Never

  None (edit)
Comment 1 Lon Hohberger 2013-10-09 16:49:09 EDT
Created attachment 810180 [details]
Fix from upstream
Comment 6 Lon Hohberger 2013-10-10 15:49:29 EDT
Created attachment 810725 [details]
Replacement patch
Comment 8 Bob Kukura 2013-11-19 09:48:32 EST
I'd like to CLOSE/WONTFIX this bug for RHOS 3.0. The main motivation for stripping the VLAN tags in tunnel payloads was to work around the performance issue whose root cause was bug 997632, which has since been fixed. Therefore, fixing this bug will not result in any further significant performance improvement.

Bug 1007158 addresses this same issue for RHOS 4.0, and is fixed. The openvswitch-agent's OVS flow rules have been reworked upstream in havana so that the VLAN tags are stripped. This involves substantial code and behavioural changes that are not practical to back-port to RHOS 3.0. Simpler possbile fixes for RHOS 3.0 have been tried, but result in all traffic being flooded to all tunnel endpoints, which would seriously limit scalability and performance.

Are there any objections to closing this?
Comment 9 Bob Kukura 2013-12-02 14:10:12 EST
Closing with WONTFIX as proposed above.

Note You need to log in before you can comment on or make changes to this bug.