Bug 1007227 - cant resume from suspend with kernel-3.11.0-x.fc20.x86_64 on Toshiba Satellite L75D-A7283
cant resume from suspend with kernel-3.11.0-x.fc20.x86_64 on Toshiba Satellit...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 03:26 EDT by collura
Modified: 2014-04-09 09:30 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-09 09:30:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
power manager utils bugreport info report (3.32 KB, text/plain)
2013-09-12 05:42 EDT, collura
no flags Details

  None (edit)
Description collura 2013-09-12 03:26:43 EDT
Description of problem:

no resume from an imposed suspend with kernel-3.11.0-x

if let screen time out (backlight remains on [gray] but) screen blanks and locks and can log back in after hitting key (then can see password prompt) and entering password.

if select toolbar menu and choose <alt>-suspend
or if you close the lid on laptop
then (backlight turns off [black] but) 
get NO response when try to resume from the suspend by:
  opening the lid or 
  by pressing a key or 
  by moving mouse or 
  by <ctl><alt><f#> or
  by <alt><f2>restart or
  by <ctl><alt><backspace> or
  by <ctl><alt><del>
  


Version-Release number of selected component (if applicable):

  fully updated fc19 system but running kernel-3.11.0.x.fc20.x86_64

How reproducible:

 always

Steps to Reproduce:
1. suspend by closing lid or by menu selection
2. fail when try to use keysequence to light up screen so can unlock
3.

Actual results:

  screen stays black 

Expected results:

  screen wakes up, enter password, get back to work

Additional info:

   aditional system information:
     https://bugzilla.redhat.com/show_bug.cgi?id=991737
     https://bugzilla.redhat.com/show_bug.cgi?id=1006527
Comment 1 collura 2013-09-12 05:42:26 EDT
Created attachment 796719 [details]
power manager utils bugreport info report
Comment 2 collura 2013-09-12 06:11:44 EDT
uncommenting the lines of /etc/acpi/events/videoconf:

 "# Configuration to turn on DPMS again on video activity, needed for some
  # laptops. Disabled by default, uncomment if your laptop display stays blank
  # after you close and open the lid.

  #event=video.*
  #action=/usr/sbin/vbetool dpms on
 "

didnt help
Comment 3 collura 2013-10-05 03:58:08 EDT
same with fedora20-alpha livecd:

   cant resume from a forced suspend but can from a screen time out.

still broken but suspend/resume process seems closer because changes to the status lights seem more sane.  before fc20alpha the power and wifi lights didnt seem to shutoff in a reliable orderly fashion when force a suspend but do now.
Comment 4 collura 2013-12-01 07:22:13 EST
not sure about kernel-3.11.9-300.fc20.x86_64 
(because was not booting when was checking) so this bug stays open.

however, since about kernel-3.13.0-0.rc1.git3.1.fc21.x86_64 and kernel-3.13.0-0.rc2.git0.1.fc21.x86_64 (which boot but dont shutdown lol) 
the resume from forced suspend is much improved but still quirky. 

(the rc1.git3.1 before resume 'top' command showed about xorg=70%cpu, gnome-shell=10%cpu but after resume 'top' showed about xorg=40% and gnome-shell=180% for  4core idles of about {before suspend 20%/60%/20%/20%, after syspend 70%/70%/70%/70%} and rc2.git0.1 was better with about {before suspend 10%/10%/10%/10%, after resume 10%/10%/10%/10% } ).
Comment 5 collura 2013-12-17 06:59:33 EST
still broken as of kernel-3.12.5-301.fc20.x86_64
(boots though after up seems to blackscreenfreeze for 30sec occasionally) 

(kernel-3.13.0-0.rc4.git0.1.fc21.x86_64 can wake up but gives fresh login screen not just password prompt and when login the running programs from the other session arent there anymore but that was another bug report)
Comment 6 Steven Marks 2014-02-16 14:21:10 EST
I observed the same problems as reporter but it not related to being a laptop. I do this on my desktop and have the same problem.

Once stuck in this state still can SSH into the computer and I observed that Xorg is taking up all the processing power. It looks like it getting in to a dead lock state. 

Are there any logs or information I can provide that will help this problem?
Comment 7 collura 2014-02-17 00:39:49 EST
still there as of kernel-3.13.2-200.fc20.x86_64

(as with comment#5, can now resume with kernel-3.13.x
 but you end up in a new session somehow so 
 you lose all previously running programs when resume.

 while suspended you press power button, 
 get fresh login screen [instead of password resume screen], 
 then it looks like its going to log you in but instead 
 screen goes black again, 
 hit escape then you get the password resume screen,
 enter password and get the desktop finally 
 but it doesnt have the programs that were running when you suspended. )

also is possibly duplicated by:

  https://bugzilla.redhat.com/show_bug.cgi?id=1059502
Comment 8 Marvin Clavey 2014-02-23 12:18:31 EST
I have the same problem as you do ... exactly... 

same as Bug 1059502


HP laptop dv7  fedora 20 
gnome 3.10.3  
Gallium 0.4 on AMD RS880

It appears to me the video driver is not initialised properly.
Comment 9 Jay Kamat 2014-03-02 14:11:55 EST
For me, kernel 3.13.5 does not fix the problem, I still get a black screen upon resuming
Comment 10 Jay Kamat 2014-04-03 03:13:19 EDT
The latest kernel (3.15) on fedora rawhide still leaves a black screen after a sleep. Is there any progress being made on this bug?
Comment 11 collura 2014-04-07 16:18:47 EDT
resume from suspend began working at some point recently 
(think was a change around 3.13.7-200 but didnt quite work if remember)
but havent tracked down when.

currently running

  dracut-034-64.git20131205.fc20.1.x86_64
  kernel-3.13.8-200.fc20.x86_64

havent tried 3.14.x or 3.15.x yet 
but see issue from comment#10 above for 3.15.x 

leaving open for now to see if continues to work for me 
and if gets fixed for others.
Comment 12 Steven Marks 2014-04-08 01:38:18 EDT
I am still seeing the issue withkernel-3.13.8-200.fc20.x86_64 and dracut-037-10.git201404021. 

I am using nvidia driver 331.49.
Comment 13 Josh Boyer 2014-04-09 09:29:47 EDT
Steven, we don't support systems using proprietary drivers.
Comment 14 Josh Boyer 2014-04-09 09:30:56 EDT
Closing since the original reporter says it works now.  Everyone else still having issues please open a new bug with your relevant details.

Note You need to log in before you can comment on or make changes to this bug.