Bug 991737 - Limited Brightness control with Radeon HD 8330 embedded in AMD A4-5000 processor apu chip
Limited Brightness control with Radeon HD 8330 embedded in AMD A4-5000 proces...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 04:16 EDT by collura
Modified: 2013-09-19 03:36 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 06:48:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (59.44 KB, text/plain)
2013-08-04 04:18 EDT, collura
no flags Details
lspci (3.66 KB, text/plain)
2013-08-04 04:19 EDT, collura
no flags Details
lsmod (3.16 KB, text/plain)
2013-08-04 04:20 EDT, collura
no flags Details
dmesg of kernel-3.11.0-0.rc5.git4.1.fc20.x86_64 no brightness change and locks up when move brightness slider (70.88 KB, text/plain)
2013-08-17 04:17 EDT, collura
no flags Details
dmesg from kernel-3.11.0-3.fc20.x86_64 (62.47 KB, text/plain)
2013-09-12 04:37 EDT, collura
no flags Details
vae log messages from kernel-3.11.0-3.fc20.x86_64 (327.36 KB, text/plain)
2013-09-12 04:38 EDT, collura
no flags Details
pm-utils-bugreport-info script output (3.32 KB, text/plain)
2013-09-12 05:53 EDT, collura
no flags Details

  None (edit)
Description collura 2013-08-04 04:16:48 EDT
Description of problem:

 Brightness remains at full and cant be changed with slider or echo backlight.

 cant change brightness of screen:
   Using 'Settings-Power-screenbrightness' slider 
   has no effect on brightness when slide to change brightness.

   or

   Using 'echo $somenumber > /sys/class/backlight/acpi_video0/brightness' 
   has no effect on brightness.

Version-Release number of selected component (if applicable):

 kernel-3.10.4-300.fc19.x86_64
 control-center-1:3.8.3-2.fc19.x86_64
 xorg-x11-drv-ati-7.1.0-5.20130408git6e74aacc5.fc19.x86_64

How reproducible:

 always

Steps to Reproduce:
1. boot and login
2. change settings-power-screenbrightness slider
3. no change in brightness

Actual results:

 no change in screen brightness when change brightness setting value

Expected results:

 screen brightness changes to desired level and remembered at next boot

Additional info:

 default brightness set to maximum and cant be turned down 
 ( at least can read screen but nearly blinding ;') )

  Toshiba Satellite L75D-A 
    AMD A4-5000 apu processor/video
    with embedded Radeon HD 8330 video chip

    with 'bios' insydeH2O v3.7 
      with 'Security-secureboot' disabled and 
      with 'Advanced-bootmode' set to csm instead of uefi

  fc19 installed 
  fully updated (over network after sneakernetting over 
                 kernel-3.10.3-300.fc19.x86_64 rpm)

  lsmod 
    toshiba_acpi 22853 0
    video 19052 0

 screen generally ok but sometimes windows have snow background noise
 in non-focus windows and sometimes in controls within focused window like 
 this text entry widget whose gradient backround colors between the 
 gray and white are snowy medium grays.
Comment 1 collura 2013-08-04 04:18:07 EDT
Created attachment 782430 [details]
dmesg
Comment 2 collura 2013-08-04 04:19:26 EDT
Created attachment 782431 [details]
lspci
Comment 3 collura 2013-08-04 04:20:17 EDT
Created attachment 782432 [details]
lsmod
Comment 4 collura 2013-08-12 20:36:41 EDT
still with:

 kernel-3.10.4-300.fc19.x86_64
 control-center-1:3.8.3-2.fc19.x86_64
 xorg-x11-drv-ati-7.1.0-5.20130408git6e74aacc5.fc19.x86_64

when run udevadm to look for changes have the following results: 

0) 'udevadm monitor' gives escape sequence carat-bracket-0Q 
    when <f2> is pressed alone
    and no change to 
      /sys/class/backlight/acpi_video0/brightness 
    or to 
      /sys/class/backlight/acpi_video0/actual_brightness
    values
    but with NO brightness down change,

   'udevadm monitor' gives escape sequence carat-bracket-0R 
    when <f3> is pressed alone 
    and no change to
      /sys/class/backlight/acpi_video0/brightness
    or to
      /sys/class/backlight/acpi_video0/actual_brightness
    values
    but with NO brightness up change,

1) 'udevadm monitor' gives NO response at all when <fcn><f2> or <fcn><f3> is pressed and with NO brightness up change,

2) 'udevadm monitor' gives at least partly normal looking response: 

      "KERNEL[623.204076] change   
         /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       UDEV  [623.216213] change   
         /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)"

   when echo a value to backlight using 
      'echo 3 > /sys/class/backlight/acpi_video0/brightness'
   and DOES change values in
      /sys/class/backlight/acpi_video0/brightness
   and in
      /sys/class/backlight/acpi_video0/actual_brightness
   values 
   but still with NO brightness change.

3) 'udevadm monitor' observation of 
    controlcenter settings-power-screenbrightness slider change 
    produces:
      "KERNEL[2417.831921] change   
          /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       UDEV  [2417.842551] change   
          /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       KERNEL[2418.266274] change   
          /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       UDEV  [2418.268112] change   
          /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       KERNEL[2418.387240] change   
          /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       UDEV  [2418.388765] change   
           /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       KERNEL[2418.556695] change   
           /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       UDEV  [2418.557900] change   
           /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       KERNEL[2418.888144] change   
           /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)
       UDEV  [2418.889048] change   
           /devices/pci0000:00/0000:00:01.0/backlight/acpi_video0 (backlight)"
   and DID change the values in
       /sys/class/backlight/acpi_video0/brightness
   and in 
       /sys/class/backlight/acpi_video0/actual_brightness
   (where brightness and actual_brightness file values were same) 
   BUT with NO CHANGE in brightness.
Comment 5 collura 2013-08-17 04:17:05 EDT
Created attachment 787523 [details]
dmesg of kernel-3.11.0-0.rc5.git4.1.fc20.x86_64 no brightness change and locks up when move brightness slider
Comment 6 collura 2013-09-02 22:13:56 EDT
kernel-3.11.0-0.rc7.git4.1.fc20.x86_64 no brightness change and locks up when move brightness slider
Comment 7 collura 2013-09-05 04:30:46 EDT
found one way to control brightness :')

at least part of the problem is for sure the kernel instead of xorg-x11-drv-ati.

currently using:

  kernel-3.11.0-3.fc20.x86_64
  linux-firmware-20130724-30.git31f6b30.fc20.x86_64
  microcode_ctl-2:2.1-1.fc20.x86_64
  control-center-1:3.8.4.1-1.fc19.x86_64
  xorg-x11-drv-ati-7.1.0-5.20130408git6e74aacc5.fc19.x86_64

only way to control the brightness is with the kernel-3.11.x :

  echo 10 > /sys/class/backlight/radeon_bl0/brightness

but echo to acpi_video0 still fails.

(the refiles would be for: function keys that still dont change brightness, and another for the brightness slider that moves but doesnt change brightness and also freezes the system, and guessing that when freezes stop that it will still be foregetful of the brightness setting after reboot. ;') )

leaving this open for now (renaming as 'limited' instead of 'no') 
until figure better way to seperate out the subsets of refiles.
Comment 8 collura 2013-09-12 04:37:31 EDT
Created attachment 796689 [details]
dmesg from kernel-3.11.0-3.fc20.x86_64
Comment 9 collura 2013-09-12 04:38:51 EDT
Created attachment 796690 [details]
vae log messages from kernel-3.11.0-3.fc20.x86_64
Comment 10 collura 2013-09-12 05:53:18 EDT
Created attachment 796736 [details]
pm-utils-bugreport-info script output
Comment 11 collura 2013-09-17 06:48:05 EDT
from comment#7 'closing after seperate out refiles' :

refiled pieces as

  https://bugzilla.redhat.com/show_bug.cgi?id=1007227 
    display not resume from suspend

  https://bugzilla.redhat.com/show_bug.cgi?id=1007241 
    slider freeze

  https://bugzilla.redhat.com/show_bug.cgi?id=1008898 
    fcn key mislabeling (including no brightness keys)


so closing this 

  https://bugzilla.redhat.com/show_bug.cgi?id=991737 
     no brightness control

as errata since kernel now has working 
  'echo to radeon_bl0' to change brightness 
[and changing to kernel since the fix didnt involve any ati drv updates :') ]

Note You need to log in before you can comment on or make changes to this bug.