Bug 100728 - KDE Classic icons badly scaled
KDE Classic icons badly scaled
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kdelibs (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-24 14:52 EDT by Peter Backlund
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 17:15:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Icons with RH KDE (44.74 KB, image/png)
2003-07-24 14:53 EDT, Peter Backlund
no flags Details
Icons with vanilla/rex KDE (24.79 KB, image/png)
2003-07-24 14:54 EDT, Peter Backlund
no flags Details

  None (edit)
Description Peter Backlund 2003-07-24 14:52:44 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux) 
 
Description of problem: 
The icon scaling patch against kdelibs produce bad appearance of mainly the KDE 
Classic icons, but also the other icon themes, when using a standard panel size 
(like "normal"). 
 
The KDE packages built by Rex Dieter, based on RH's packages, available on 
kde-redhat.sf.net, do not have this behaviour. I'll have to get back to you on 
exactly what the difference is, but for now I have two screenshots showing the 
classic icons with and without the scaling patch. Notice the blurry, upsized look of 
the RH kicker icons. It seems to me as vanilla KDE uses 32x32 icons with size 
"normal" panel, but RH scales them up slightly.  
 
Version-Release number of selected component (if applicable): 
kdelibs-3.1.2-7 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Populate the KDE panel with KDE application icons (konq, kmail, kcontrol etc). 
2. Switch to KDE classic icon theme. 
3. Set panel size to normal. 
     
 
Actual Results:  Icons look bad. 
 
Expected Results:  Icons should not be up-scaled. 
 
Additional info:
Comment 1 Peter Backlund 2003-07-24 14:53:29 EDT
Created attachment 93115 [details]
Icons with RH KDE
Comment 2 Peter Backlund 2003-07-24 14:54:05 EDT
Created attachment 93116 [details]
Icons with vanilla/rex KDE
Comment 3 Ngo Than 2003-07-30 17:15:02 EDT
i would say it's a feature, not a bug. But if you want to disable this option
you should add IconResize=false in /usr/share/config/kdeglobals

....

[PanelIcons]
Size=48
IconResize=false

....

Info: you need new kdebase-3.1.3-1 or newer for doing that. KDE 3.1.3 will be
available in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.