Bug 1007281 - mountstats command could not process the argument /mountpoint/
Summary: mountstats command could not process the argument /mountpoint/
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils
Version: 6.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks: 1007283 1007287 1198596
TreeView+ depends on / blocked
 
Reported: 2013-09-12 08:48 UTC by JianHong Yin
Modified: 2015-07-22 06:49 UTC (History)
4 users (show)

Fixed In Version: nfs-utils-1.2.3-56.el6
Doc Type: Bug Fix
Doc Text:
Previously, the mountstats tool incorrectly parsed arguments that ended with the slash character (/). Consequently, the mountstats command failed when the directory name included a slash at the end. This bug has been fixed, and mountstats no longer fails in this scenario.
Clone Of:
: 1007283 1007287 1198596 (view as bug list)
Environment:
Last Closed: 2015-07-22 06:49:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1342 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2015-07-20 17:54:08 UTC

Description JianHong Yin 2013-09-12 08:48:48 UTC
Description of problem:
mountstats command could not process the  argument /mountpoint/
mountstats  /mountpoint   work fine
mountstats  /mountpoint/  can not work

Version-Release number of selected component (if applicable):
all RHEL5.9,10 RHEL6.4,5 RHEL7.0

How reproducible:
100%

Steps to Reproduce:
1. mountstats  /mountpoint/
2.
3.

Actual results:
[root@dhcp-13-188 ~]# mountstats  /media/
Statistics for mount point /media/ not found
[root@dhcp-13-188 ~]# mountstats  /media
Stats for 127.0.0.1:/tmp/ mounted on /media:
  NFS mount options: rw,vers=4,rsize=131072,wsize=131072,namlen=255,acregmin=3,acregmax=60,acdirmin=30,acdirmax=60,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=127.0.0.1,minorversion=0,local_lock=none
  NFS server capabilities: caps=0xffff,wtmult=512,dtsize=32768,bsize=0,namlen=255
  NFSv4 capability flags: bm0=0xfdffbfff,bm1=0xf9be3e,acl=0x3
  NFS security flavor: 1  pseudoflavor: 0

NFS byte counts:
  applications read 0 bytes via read(2)
  applications wrote 0 bytes via write(2)
  applications read 0 bytes via O_DIRECT read(2)
  applications wrote 0 bytes via O_DIRECT write(2)
  client read 0 bytes via NFS READ
  client wrote 0 bytes via NFS WRITE

RPC statistics:
  18 RPC requests sent, 18 RPC replies received (0 XIDs not found)
  average backlog queue length: 0

FSINFO:
        1 ops (5%)      0 retrans (0%)  0 major timeouts
        avg bytes sent per op: 160      avg bytes received per op: 108
        backlog wait: 0.000000  RTT: 0.000000   total execute time: 0.000000 (milliseconds)
GETATTR:
        2 ops (11%)     0 retrans (0%)  0 major timeouts
        avg bytes sent per op: 160      avg bytes received per op: 220
        backlog wait: 0.000000  RTT: 1.000000   total execute time: 2.500000 (milliseconds)
PATHCONF:
        1 ops (5%)      0 retrans (0%)  0 major timeouts
        avg bytes sent per op: 156      avg bytes received per op: 72
        backlog wait: 0.000000  RTT: 0.000000   total execute time: 0.000000 (milliseconds)
SERVER_CAPS:
        2 ops (11%)     0 retrans (0%)  0 major timeouts
        avg bytes sent per op: 156      avg bytes received per op: 88
        backlog wait: 0.000000  RTT: 0.000000   total execute time: 0.000000 (milliseconds)

Expected results:
mountstats  /mountpoint/  can work too, same as mountstats  /mountpoint

Additional info:

Comment 2 RHEL Product and Program Management 2013-10-14 02:13:43 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 Yongcheng Yang 2015-03-06 02:22:58 UTC
VERIFIED on nfs-utils-1.2.3-56.el6.x86_64.rpm 
=============================================
https://beaker.engineering.redhat.com/jobs/897439

[21:09:49 root@ ~~]# mountstats $nfsmp/
Stats for intel-chiefriver-01.lab.eng.rdu.redhat.com:/exportDir-bz1172827 mounted on /mnt/nfsmp-bz1172827:
  NFS mount options: rw,vers=3,rsize=524288,wsize=524288,namlen=255,acregmin=3,acregmax=60,acdirmin=30,acdirmax=60,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=10.12.0.54,mountvers=3,mountport=32770,mountproto=udp,local_lock=none
  NFS server capabilities: caps=0x3fef,wtmult=4096,dtsize=4096,bsize=0,namlen=255
  NFS security flavor: 1  pseudoflavor: 0

NFS byte counts:
  applications read 0 bytes via read(2)
  applications wrote 0 bytes via write(2)
  applications read 0 bytes via O_DIRECT read(2)
  applications wrote 0 bytes via O_DIRECT write(2)
  client read 0 bytes via NFS READ
  client wrote 0 bytes via NFS WRITE

RPC statistics:
  7 RPC requests sent, 7 RPC replies received (0 XIDs not found)
  average backlog queue length: 0

GETATTR:
	2 ops (28%) 
	avg bytes sent per op: 112	avg bytes received per op: 112
	backlog wait: 0.000000 	RTT: 0.000000 	total execute time: 0.000000 (milliseconds)
FSINFO:
	2 ops (28%) 
	avg bytes sent per op: 112	avg bytes received per op: 80
	backlog wait: 0.000000 	RTT: 0.000000 	total execute time: 0.000000 (milliseconds)
PATHCONF:
	1 ops (14%) 
	avg bytes sent per op: 112	avg bytes received per op: 56
	backlog wait: 0.000000 	RTT: 0.000000 	total execute time: 0.000000 (milliseconds)

:: [   PASS   ] :: bz1007287 (Expected 0, got 0)
=============================================
Move to VERIFIED

Comment 6 errata-xmlrpc 2015-07-22 06:49:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1342.html


Note You need to log in before you can comment on or make changes to this bug.