Bug 1007287 - mountstats command could not process the argument /mountpoint/
mountstats command could not process the argument /mountpoint/
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils (Show other bugs)
7.0
All Linux
high Severity low
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
:
Depends On: 1007281 1198596
Blocks: 1007283
  Show dependency treegraph
 
Reported: 2013-09-12 04:52 EDT by Yin.JianHong
Modified: 2016-02-23 10:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1007281
Environment:
Last Closed: 2016-02-11 11:06:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-09-12 04:52:16 EDT
+++ This bug was initially created as a clone of Bug #1007281 +++

Description of problem:
mountstats command could not process the  argument /mountpoint/
mountstats  /mountpoint   work fine
mountstats  /mountpoint/  can not work

Version-Release number of selected component (if applicable):
all RHEL5.9,10 RHEL6.4,5 RHEL7.0

How reproducible:
100%

Steps to Reproduce:
1. mountstats  /mountpoint/
2.
3.

Actual results:
[root@dhcp-13-188 ~]# mountstats  /media/
Statistics for mount point /media/ not found
[root@dhcp-13-188 ~]# mountstats  /media
Stats for 127.0.0.1:/tmp/ mounted on /media:
  NFS mount options: rw,vers=4,rsize=131072,wsize=131072,namlen=255,acregmin=3,acregmax=60,acdirmin=30,acdirmax=60,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=127.0.0.1,minorversion=0,local_lock=none
  NFS server capabilities: caps=0xffff,wtmult=512,dtsize=32768,bsize=0,namlen=255
  NFSv4 capability flags: bm0=0xfdffbfff,bm1=0xf9be3e,acl=0x3
  NFS security flavor: 1  pseudoflavor: 0

NFS byte counts:
  applications read 0 bytes via read(2)
  applications wrote 0 bytes via write(2)
  applications read 0 bytes via O_DIRECT read(2)
  applications wrote 0 bytes via O_DIRECT write(2)
  client read 0 bytes via NFS READ
  client wrote 0 bytes via NFS WRITE

RPC statistics:
  18 RPC requests sent, 18 RPC replies received (0 XIDs not found)
  average backlog queue length: 0

FSINFO:
        1 ops (5%)      0 retrans (0%)  0 major timeouts
        avg bytes sent per op: 160      avg bytes received per op: 108
        backlog wait: 0.000000  RTT: 0.000000   total execute time: 0.000000 (milliseconds)
GETATTR:
        2 ops (11%)     0 retrans (0%)  0 major timeouts
        avg bytes sent per op: 160      avg bytes received per op: 220
        backlog wait: 0.000000  RTT: 1.000000   total execute time: 2.500000 (milliseconds)
PATHCONF:
        1 ops (5%)      0 retrans (0%)  0 major timeouts
        avg bytes sent per op: 156      avg bytes received per op: 72
        backlog wait: 0.000000  RTT: 0.000000   total execute time: 0.000000 (milliseconds)
SERVER_CAPS:
        2 ops (11%)     0 retrans (0%)  0 major timeouts
        avg bytes sent per op: 156      avg bytes received per op: 88
        backlog wait: 0.000000  RTT: 0.000000   total execute time: 0.000000 (milliseconds)

Expected results:
mountstats  /mountpoint/  can work too, same as mountstats  /mountpoint

Additional info:
Comment 2 RHEL Product and Program Management 2014-03-22 02:38:55 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Steve Dickson 2016-01-20 11:58:10 EST
commit e24ba8a24d3ebfa6388a74523e61f2cad179c0c2
Author: Scott Mayhew <smayhew@redhat.com>
Date:   Wed Mar 4 08:11:35 2015 -0500

    mountstats: Normalize the mountpoints passed on the command line.
    
    Normalize the mountpoints passed on the command line so that commands
    like 'mountstats /mnt/' succeed rather than fail.
    
    Signed-off-by: Scott Mayhew <smayhew@redhat.com>
    Signed-off-by: Steve Dickson <steved@redhat.com>
Comment 6 Steve Dickson 2016-02-11 11:06:21 EST

*** This bug has been marked as a duplicate of bug 1215808 ***

Note You need to log in before you can comment on or make changes to this bug.