Bug 1007360 - Cannot redeploy Business Central - fails with NoClassDefFoundError
Cannot redeploy Business Central - fails with NoClassDefFoundError
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
urgent Severity urgent
: ER4
: 6.0.0
Assigned To: Alexandre Porcelli
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 06:38 EDT by Jiri Locker
Modified: 2014-08-06 16:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
JBoss EAP 6.1.0
Last Closed: 2014-08-06 16:09:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (158.33 KB, text/plain)
2013-09-12 06:38 EDT, Jiri Locker
no flags Details

  None (edit)
Description Jiri Locker 2013-09-12 06:38:48 EDT
Created attachment 796761 [details]
server.log

Description of problem:
Not possible to redeploy business-central.war. When it's deployed it can be successfully undeployed but after that, any attempt to deploy it again will fail due to NoClassDefFoundError: Could not initialize class org.kie.commons.java.nio.file.api.FileSystemProviders$FileSystemProvidersHolder raised during Weld @PostConstruct phase.

It is not possible to redeploy Business Central without restarting application server.

Version-Release number of selected component (if applicable):
ER2

How reproducible:
always

Steps to Reproduce:
1. start server (with business-central.war.dodeploy marker)
2. undeploy (rm business-central.war.deployed)
3. deploy again (touch business-central.war.dodeploy)

Actual results:
Deployment fails.

Expected results:
Should deploy successfully.

Additional info:
The attached server.log is complete but you may skip to 10:59:31,764 where the server start is completed. Then business-central.war deployment is stopped and started again. The error is logged at 11:01:26,668 ERROR.
Comment 2 Rajesh Rajasekaran 2013-10-29 07:22:03 EDT
Marking it as MODIFIED based on last comment. Please verify in ER4
Comment 3 Jiri Locker 2013-10-30 08:24:58 EDT
Fixed in ER4. Redeploy tested both with marker files and from EAP Management console.
Comment 4 Lukáš Petrovický 2014-02-07 11:14:59 EST
This BZ has been part of the 6.0.0 stream.

Note You need to log in before you can comment on or make changes to this bug.