Bug 1007400 - /CoreOS/tar/Regression/bz518079-memory-leak-in-tar-xattr fails on ppc64
/CoreOS/tar/Regression/bz518079-memory-leak-in-tar-xattr fails on ppc64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: valgrind (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mark Wielaard
Miloš Prchlík
:
Depends On: 977416
Blocks: 1056252
  Show dependency treegraph
 
Reported: 2013-09-12 08:20 EDT by Alex Sersen
Modified: 2014-10-14 02:36 EDT (History)
8 users (show)

See Also:
Fixed In Version: valgrind-3.8.1-3.3.el6
Doc Type: Bug Fix
Doc Text:
Cause: Valgrind didn't support the [lf]setxattr system calls on ppc32 and ppc64 linux kernels. Consequence: Programs using those system calls when running under valgrind would get warnings and errors. Fix: valgrind now recognizes those system calls and handles them properly. Result: Programs running under valgrind on ppc that use [lf]setxattr system calls run without warnings or errors.
Story Points: ---
Clone Of: 977416
Environment:
Last Closed: 2014-10-14 02:36:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 321969 None None None Never
Red Hat Product Errata RHBA-2014:1464 normal SHIPPED_LIVE valgrind bug fix update 2014-10-13 21:10:53 EDT

  None (edit)
Description Alex Sersen 2013-09-12 08:20:22 EDT
Same problem on RHEL6.5-20130830.2

+++ This bug was initially created as a clone of Bug #977416 +++

Description of problem:
valgrind fails with "WARNING: unhandled syscall: 209" error on ppc64 arch.
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2013/06/4360/436002/916777/13195208/TESTOUT.log


Version-Release number of selected component (if applicable):


How reproducible:
run test [1] 

[1] http://pkgs.devel.redhat.com/cgit/tests/tar/tree/Regression/bz518079-memory-leak-in-tar-xattr
Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Alex Sersen on 2013-06-24 10:04:49 EDT ---

Affected version:
valgrind-3.5.0-5.el5

--- Additional comment from Mark Wielaard on 2013-07-04 16:35:04 EDT ---

209 is setxattr

--- Additional comment from Mark Wielaard on 2013-07-04 17:24:09 EDT ---

This is also a problem with upstream svn trunk.
I filed a bug and provided a patch:
https://bugs.kde.org/show_bug.cgi?id=321969

--- Additional comment from Mark Wielaard on 2013-07-05 05:52:39 EDT ---

This is now fixed upstream as svn commit r13449.

--- Additional comment from Mark Wielaard on 2013-07-08 17:45:38 EDT ---

Also in fedora valgrind-3.8.1-17 now.
Comment 4 Miloš Prchlík 2014-06-03 08:21:18 EDT
Verified for build valgrind-3.8.1-3.5.el6.
Comment 5 errata-xmlrpc 2014-10-14 02:36:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1464.html

Note You need to log in before you can comment on or make changes to this bug.