This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 977416 - /CoreOS/tar/Regression/bz518079-memory-leak-in-tar-xattr fails on ppc64
/CoreOS/tar/Regression/bz518079-memory-leak-in-tar-xattr fails on ppc64
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: valgrind (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Mark Wielaard
qe-baseos-tools
:
Depends On:
Blocks: 1007400
  Show dependency treegraph
 
Reported: 2013-06-24 09:54 EDT by Alex Sersen
Modified: 2013-11-26 11:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1007400 (view as bug list)
Environment:
Last Closed: 2013-11-26 11:33:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 321969 None None None Never

  None (edit)
Description Alex Sersen 2013-06-24 09:54:04 EDT
Description of problem:
valgrind fails with "WARNING: unhandled syscall: 209" error on ppc64 arch.
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2013/06/4360/436002/916777/13195208/TESTOUT.log


Version-Release number of selected component (if applicable):


How reproducible:
run test [1] 

[1] http://pkgs.devel.redhat.com/cgit/tests/tar/tree/Regression/bz518079-memory-leak-in-tar-xattr
Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Alex Sersen 2013-06-24 10:04:49 EDT
Affected version:
valgrind-3.5.0-5.el5
Comment 2 Mark Wielaard 2013-07-04 16:35:04 EDT
209 is setxattr
Comment 3 Mark Wielaard 2013-07-04 17:24:09 EDT
This is also a problem with upstream svn trunk.
I filed a bug and provided a patch:
https://bugs.kde.org/show_bug.cgi?id=321969
Comment 4 Mark Wielaard 2013-07-05 05:52:39 EDT
This is now fixed upstream as svn commit r13449.
Comment 5 Mark Wielaard 2013-07-08 17:45:38 EDT
Also in fedora valgrind-3.8.1-17 now.
Comment 7 mbenitez 2013-11-26 11:33:32 EST
From devel:
That would be nice to have, but not super important IMHO.
Marked dev_ack+ because it has a trivial fix. It is for ppc64, so DTS will
not help there. It would be somewhat helpful for our own QE.

Due to low priority this won't make 5.11 ACL

Note You need to log in before you can comment on or make changes to this bug.