Bug 1007494 - Remote-Viewer: Remove Unnecessary Warning Log
Summary: Remote-Viewer: Remove Unnecessary Warning Log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1021350
TreeView+ depends on / blocked
 
Reported: 2013-09-12 15:12 UTC by Vimal Patel
Modified: 2014-10-14 06:29 UTC (History)
11 users (show)

Fixed In Version: virt-viewer-0.6.0-1.el6
Doc Type: Bug Fix
Doc Text:
no doc required
Clone Of:
: 1021350 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:29:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1379 0 normal SHIPPED_LIVE virt-viewer bug fix update 2014-10-14 01:05:43 UTC

Description Vimal Patel 2013-09-12 15:12:17 UTC
Description of problem:
When closing out a remote-viewer window by selecting View->Displays->Display 1 menu option, remote viewer closes out as expected; however, it prints an unnecessary warning logging message (to stdout):

(remote-viewer:12475): remote-viewer-WARNING **: (virt-viewer-app.c:346):virt_viewer_app_window_set_visible: code should not be reached.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-7.el6.x86_64 

How reproducible:
100%

Steps to Reproduce:
1. connect to a VM using remote-viewer spice://<host>:<port>
2. close the rv window by selecting View->Displays->Display 1
3.

Actual results:
warning log displayed:
(remote-viewer:12475): remote-viewer-WARNING **: (virt-viewer-app.c:346):virt_viewer_app_window_set_visible: code should not be reached.

Expected results:
no logs

Additional info:

Comment 2 tingting zheng 2013-10-21 06:58:31 UTC
I can reproduce this bug with:virt-viewer-0.5.6-8.el6.x86_64

Comment 4 Jonathon Jongsma 2014-02-14 16:38:22 UTC
already fixed upstream in f4b7f3321c364b5f744ef5a28827077d06c2005f

Comment 6 Cui Lei 2014-06-05 05:31:12 UTC
I can reproduce this issue with virt-viewer-0.5.6-10.el6.x86_64.

Verify it with virt-viewer-0.6.0-4.el6:
1. connect to a VM using remote-viewer spice://<host>:<port>
2. close the rv window by selecting View->Displays->Display 1

There is no warning message after close the window.

So change the status from 'ON_QA' to 'VERIFIED'.

Comment 7 errata-xmlrpc 2014-10-14 06:29:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html


Note You need to log in before you can comment on or make changes to this bug.