Bug 1021350 - Remote-Viewer: Remove Unnecessary Warning Log
Summary: Remote-Viewer: Remove Unnecessary Warning Log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Virt Viewer Maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1007494
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-21 07:04 UTC by tingting zheng
Modified: 2015-03-05 13:38 UTC (History)
10 users (show)

Fixed In Version: virt-viewer-0.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: A meaningless warning was printed to the console when exiting the application by disabling the last display Fix: Remove warning Result: No warnings when exiting the application
Clone Of: 1007494
Environment:
Last Closed: 2015-03-05 13:38:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0295 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2015-03-05 17:33:00 UTC

Description tingting zheng 2013-10-21 07:04:12 UTC
The bug can also be reproduced on rhel7,so cloned the bug.

+++ This bug was initially created as a clone of Bug #1007494 +++

Description of problem:
When closing out a remote-viewer window by selecting View->Displays->Display 1 menu option, remote viewer closes out as expected; however, it prints an unnecessary warning logging message (to stdout):

(remote-viewer:12475): remote-viewer-WARNING **: (virt-viewer-app.c:346):virt_viewer_app_window_set_visible: code should not be reached.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-7.el6.x86_64 

How reproducible:
100%

Steps to Reproduce:
1. connect to a VM using remote-viewer spice://<host>:<port>
2. close the rv window by selecting View->Displays->Display 1
3.

Actual results:
warning log displayed:
(remote-viewer:12475): remote-viewer-WARNING **: (virt-viewer-app.c:346):virt_viewer_app_window_set_visible: code should not be reached.

Expected results:
no logs

Additional info:

--- Additional comment from RHEL Product and Program Management on 2013-09-12 11:22:59 EDT ---

Since this bug report was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from tingting zheng on 2013-10-21 02:58:31 EDT ---

I can reproduce this bug with:virt-viewer-0.5.6-8.el6.x86_64

Comment 1 CongDong 2013-11-21 03:19:09 UTC
I can reproduce this with:
virt-viewer-0.5.7-2.el7.x86_64

Steps:
1. connect to a VM using remote-viewer spice://<host>:<port>
2. close the rv window by selecting View->Displays->Display 1

Result:
warning log displayed:
(remote-viewer:3106): remote-viewer-WARNING **: (virt-viewer-app.c:354):virt_viewer_app_window_set_visible: code should not be reached

Comment 2 Marc-Andre Lureau 2013-11-21 10:25:05 UTC
sent patch:
https://www.redhat.com/archives/virt-tools-list/2013-November/msg00089.html

Comment 3 Jonathon Jongsma 2014-07-10 02:35:33 UTC
fixed by rebase to 0.6.0

Comment 5 tingting zheng 2014-07-22 05:41:49 UTC
I can reproduce this bug with:
virt-viewer-0.5.7-7.el7.x86_64

Tested pass with:
virt-viewer-0.6.0-1.el7.x86_64

Steps are refer to the description,since no such warning info shows,move the bug to VERIFIED.

Comment 7 errata-xmlrpc 2015-03-05 13:38:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html


Note You need to log in before you can comment on or make changes to this bug.