Bug 1007520 - denyhosts.service operation timed out. Terminating.
denyhosts.service operation timed out. Terminating.
Status: CLOSED DUPLICATE of bug 1129747
Product: Fedora
Classification: Fedora
Component: denyhosts (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason Tibbitts
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 12:27 EDT by Daniel
Modified: 2014-12-14 11:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1129747 (view as bug list)
Environment:
Last Closed: 2014-12-14 11:41:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel 2013-09-12 12:27:52 EDT
Description of problem:

On a server I installed the denyhosts package and enabled the service with
/bin/systemctl enable denyhosts.service.
In order to test the service before reboot I started with command: /bin/systemctl start denyhosts.service and got the following error messages:

systemd[1]: denyhosts.service operation timed out. Terminating.
systemd[1]: Unit denyhosts.service entered failed state.
systemd[1]: Failed to start SSH log watcher.
systemd[1]: Unit denyhosts.service entered failed state.

I tried to restart it (even with a reboot) via 
/bin/systemctl restart denyhosts.service and got the same error messages.
Stracing the whole thing brought no results.

The solution to the problem was, to start the denyhosts service without using systemd: /usr/bin/denyhosts.py --daemon --config=/etc/denyhosts.conf.
This took a pretty long time but went through without any error messages.

After this I could even start, stop and restart denyhosts via systemd with the above mentioned commands.

So this may be rather a systemd bug than a denyhosts bug.

Version-Release number of selected component (if applicable):

denyhosts-2.6-28.fc19.noarch
Comment 1 Ralf Baechle 2014-08-13 11:03:36 EDT
I'm also observing the exact same issue on Fedora 20.
Comment 2 Till Maas 2014-12-14 11:41:02 EST

*** This bug has been marked as a duplicate of bug 1129747 ***

Note You need to log in before you can comment on or make changes to this bug.