Bug 1129747 - denyhosts.service operation timed out. Terminating.
Summary: denyhosts.service operation timed out. Terminating.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: denyhosts
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jason Tibbitts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1007520 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-13 15:06 UTC by Ralf Baechle
Modified: 2015-02-05 20:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1007520
Environment:
Last Closed: 2015-02-05 20:36:52 UTC


Attachments (Terms of Use)

Description Ralf Baechle 2014-08-13 15:06:52 UTC
+++ This bug was initially created as a clone of Bug #1007520 +++

Description of problem:

On a server I installed the denyhosts package and enabled the service with
/bin/systemctl enable denyhosts.service.
In order to test the service before reboot I started with command: /bin/systemctl start denyhosts.service and got the following error messages:

systemd[1]: denyhosts.service operation timed out. Terminating.
systemd[1]: Unit denyhosts.service entered failed state.
systemd[1]: Failed to start SSH log watcher.
systemd[1]: Unit denyhosts.service entered failed state.

I tried to restart it (even with a reboot) via 
/bin/systemctl restart denyhosts.service and got the same error messages.
Stracing the whole thing brought no results.

The solution to the problem was, to start the denyhosts service without using systemd: /usr/bin/denyhosts.py --daemon --config=/etc/denyhosts.conf.
This took a pretty long time but went through without any error messages.

After this I could even start, stop and restart denyhosts via systemd with the above mentioned commands.

So this may be rather a systemd bug than a denyhosts bug.

Version-Release number of selected component (if applicable):

denyhosts-2.6-28.fc19.noarch

--- Additional comment from Ralf Baechle on 2014-08-13 11:03:36 EDT ---

I'm also observing the exact same issue on Fedora 20.

Comment 1 Ralf Baechle 2014-08-13 15:08:15 UTC
Setting Severity to high because the CPU load caused by sshd scanning is serious.

Comment 2 Jason Tibbitts 2014-08-14 17:25:27 UTC
Processing existing logs can take some time.  Either process them separately as described in README.fedora or rotate your logs and let denyhosts work with a fresh file.

Comment 3 Till Maas 2014-12-14 16:41:02 UTC
*** Bug 1007520 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.