Bug 1007649 - Remove menu item "Automatically resize"
Remove menu item "Automatically resize"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marc-Andre Lureau
Virtualization Bugs
: Reopened
Depends On:
Blocks: 1007666
  Show dependency treegraph
 
Reported: 2013-09-12 23:46 EDT by CongDong
Modified: 2014-10-14 02:29 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-2.el6
Doc Type: Bug Fix
Doc Text:
Cause: The "Automatically resize" check menu was ambigous and not always working depending on protocol and capability of guest. Consequence: The menu wasn't reliable and useful. Fix: Remove the "Automatically resize" check menu. Result: The automatic guest resize will be enabled whenever the required conditions are met.
Story Points: ---
Clone Of:
: 1007666 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:29:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongDong 2013-09-12 23:46:48 EDT
Description of problem:
Connect a guest with virt-viewer, and check on "Automatically resize"
item, but the effect is same with check off the item.
Whether the guest is spice or vnc, I tried both win7-64 and rhel6.4.

Version-Release number of selected component (if applicable):
# rpm -qa libvirt virt-viewer spice-gtk
virt-viewer-0.5.6-7.el6.x86_64
libvirt-0.10.2-24.el6.x86_64
spice-gtk-0.20-8.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a guest(spice or vnc are both ok), if use spice guest, stop service spice-vdagentd in guest.
2.# virt-viewer $guest, and check on the "Automatically resize" item.
3.Try to resize the virt-viewer window, and check the guest resolution.
4.Check off the "Automatically resize" item, and repeat step 3.

Actual results:
The result for step3 and step4 are the same, the display will match the current window*zoom size.

Expected results:
If check off the "Automatically resize" Item, the display should not match the current window*zoom size.

Additional info:
Comment 2 Jonathon Jongsma 2013-10-14 15:07:34 EDT
I don't really understand why you're stopping the vdagent service (step 1 in steps to reproduce).  If you stop the vdagent, it will not be possible to resize the guest display automatically.  Does it work properly when vdagent is running?
Comment 3 CongDong 2013-10-14 21:47:57 EDT
(In reply to Jonathon Jongsma from comment #2)
> I don't really understand why you're stopping the vdagent service (step 1 in
> steps to reproduce).  If you stop the vdagent, it will not be possible to
> resize the guest display automatically.  Does it work properly when vdagent
> is running?

Hi:

That's what I'm not sure, what's the function of the auto-resize? 
It will change the resolution or the zoom level. So I stop the vdagent to check the zoom level.

1. If it reacts on the resolution for the guest, the spice guest is ok, but it doesn't work for the vnc guest.If it only for spice guest to auto-resize the resolution like you said, it's better to disabled the item for vnc guest.

2. If it reacts on the zoom level, I didn't find the difference wether I checked it on or off.
Comment 4 Jonathon Jongsma 2013-10-15 12:46:12 EDT
auto-resize only works for spice guests that have a vdagent.  When the client window is resized, it will attempt to update the resolution of the guest to match the resolution of the client window.  It does this by sending a message to the vdagent.

So the 'Automatically resize' menu item should probably be disabled for VNC and non-vdagent spice guests.
Comment 5 David Blechter 2013-10-15 14:58:59 EDT
running vd-agent is MUST for auto-resize feature to work, and it is for the spice only.
Closing as NOTABUG
Comment 6 Cui Lei 2013-10-15 23:10:39 EDT
Please consider the issue in comment3 descriptive:
"If it only for spice guest to auto-resize the resolution like you said, it's better to disabled the item for vnc guest."

As there is no related doc explain that, we should disable the item(make the item gray like 'USB device selection' in menu) in menu if it is useless in VNC display mode.
Comment 8 Marc-Andre Lureau 2014-03-12 10:05:38 EDT
taking that
Comment 10 Christophe Fergeau 2014-03-20 11:51:53 EDT
(In reply to Marc-Andre Lureau from comment #9)
> ->POST:
> https://www.redhat.com/archives/virt-tools-list/2014-March/msg00062.html

I think what went in in the end was https://www.redhat.com/archives/virt-tools-list/2014-March/msg00080.html
Comment 12 zhoujunqin 2014-06-05 05:37:39 EDT
I can reproduce this issue with:
virt-viewer-0.5.6-10.el6.x86_64

Verify this issue with virt-viewer-0.6.0-4.el6

step:
1.Prepare a guest(spice or vnc are both ok).
2.# virt-viewer $guest, then click menu "View", check "Automatically resize" item has been removed.

so change the status from 'ON_QA' to 'VERIFIED'.
Comment 13 errata-xmlrpc 2014-10-14 02:29:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html

Note You need to log in before you can comment on or make changes to this bug.