Bug 1007666 - Menu item "Automatically resize" could be disabled if there is no spice vdagent connection
Menu item "Automatically resize" could be disabled if there is no spice vdage...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1007649
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 01:18 EDT by CongDong
Modified: 2015-03-05 08:38 EST (History)
8 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el7
Doc Type: Bug Fix
Doc Text:
Cause: The "Automatically resize" check menu was ambigous and not always working depending on protocol and capability of guest. Consequence: The menu wasn't reliable and useful. Fix: Remove the "Automatically resize" check menu. Result: The automatic guest resize will be enabled whenever the required conditions are met.
Story Points: ---
Clone Of: 1007649
Environment:
Last Closed: 2015-03-05 08:38:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Marc-Andre Lureau 2014-07-02 11:42:59 EDT
see original bug and https://www.redhat.com/archives/virt-tools-list/2014-March/msg00080.html
Comment 5 CongDong 2014-07-22 08:09:00 EDT
I can reproduce with: virt-viewer-0.5.7-7.el7.x86_64

VERIFY with: virt-viewer-0.6.0-1.el7.x86_64

Steps:
1. Prepare a guest with spice + qxl
2. start the guest and open with virt-viewre
# virsh start $vm
# virt-viewer $vm

Result:
Option "Automatically resize" has been removed.
Run spice vdagentd service in guest, and change the window size,
guest can change the resolution automatically.

vnc guest will zoom in or out the display size to match the window size.

The result is expected.
So set VERIFIED.
Comment 7 errata-xmlrpc 2015-03-05 08:38:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0295.html

Note You need to log in before you can comment on or make changes to this bug.