Bug 1007653 - Firefox spell checking loses specific dialect in language setting
Firefox spell checking loses specific dialect in language setting
Status: CLOSED DUPLICATE of bug 439598
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
21
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 00:06 EDT by austinenglish
Modified: 2015-10-16 14:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 14:34:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description austinenglish 2013-09-13 00:06:29 EDT
Howdy,

I'm running Firefox 21.0 on Fedora 18. I run with an en_US.UTF-8 locale, but have Arabic language support installed (was testing an unrelated bug..). I've noticed that when I start Firefox and begin typing in forms that have spell checking, ALL words are wrong. If I right click and look at the selected language, it defaults to 'Arabic (Oman)'. If I set it to English (United States), it's fine, until I start a new Firefox session.

Reproducible: every restart
Comment 1 Martin Stransky 2013-09-16 03:10:39 EDT
Can you test it in safe mode (https://fedoraproject.org/wiki/How_to_debug_Firefox_problems) and if the problem persist try an upstream binary from mozilla.com?

Thanks.
Comment 2 austinenglish 2013-09-17 03:26:28 EDT
(In reply to Martin Stransky from comment #1)
> Can you test it in safe mode

The bug persists in safe mode.

> (https://fedoraproject.org/wiki/How_to_debug_Firefox_problems) and if the
> problem persist try an upstream binary from mozilla.com?

Used:
[austin@localhost ~]$ sha1sum firefox-23.0.1.tar.bz2 
a2eab7e7ffcb7a02c0a4baed9f7eda3ccbe60d62  firefox-23.0.1.tar.bz2

which does not come with Arabic installed. I installed the Arabic dictionary/language pack, restarted, and the default language remained English. I should note that Arabic was only one langauge in upstream 23.0.1, instead of the few dozen country/language combos.

FWIW though, I've had a similar issue with a gentoo FF 22.0 installation, which likes to default to Canadian English instead of US English.
Comment 3 Martin Stransky 2013-09-17 05:35:45 EDT
You can get the localized version here:

ftp://ftp.mozilla.org/pub/firefox/releases/24.0/linux-x86_64/

or

ftp://ftp.mozilla.org/pub/firefox/releases/24.0/linux-i686/

but I'm not sure how it's related to this bug.
Comment 4 austinenglish 2013-10-17 00:43:27 EDT
https://bugzilla.mozilla.org/show_bug.cgi?id=836882 may be related
Comment 5 Matthew Miller 2013-11-08 13:03:50 EST
This problem exists with English, too. In previous releases, I was always getting reset to English (Hong Kong), but now it seems that English (Zimbabwe) tops the list. This is a rather annoying usability quirk.
Comment 6 Garrett Mitchener 2014-03-26 12:38:45 EDT
Related to Bug #643954
Comment 7 Matthew Miller 2014-11-06 00:18:10 EST
Still happening in F21 beta.

However, I did discover an effective workaround if you just want US English:

  dnf remove hunspell-en hunspell-en-GB

Apparently, hunspell-en-US is its own package. You could do the same with keeping GB, of course. If you want one of the other variants, you're less fortunate, but, actually, all of those but CA are actually just symlinks to GB.
Comment 8 Matthew Miller 2015-10-16 14:34:12 EDT

*** This bug has been marked as a duplicate of bug 439598 ***

Note You need to log in before you can comment on or make changes to this bug.