Bug 1007685 - openstack-status still uses quantum named services instead of neutron
openstack-status still uses quantum named services instead of neutron
Status: CLOSED DUPLICATE of bug 999507
Product: RDO
Classification: Community
Component: openstack-utils (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pádraig Brady
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 02:49 EDT by Attila Fazekas
Modified: 2016-01-04 09:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 09:06:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Fazekas 2013-09-13 02:49:31 EDT
Description of problem:
openstack-status does not shows neutron service status.

[root@rhel-6 nova(keystone_admin)]# grep neutron /usr/bin/openstack-status
[root@rhel-6 nova(keystone_admin)]# grep quantum /usr/bin/openstack-status
rpm -q openstack-quantum > /dev/null && quantum='quantum'
if test "$quantum"; then
  for svc in quantum-server quantum-dhcp-agent quantum-l3-agent quantum-linuxbridge-agent quantum-openvswitch-agent openvswitch; do check_svc "$svc"; done


Version-Release number of selected component (if applicable):
RDO havana

http://repos.fedorapeople.org/repos/openstack/openstack-havana/epel-6/openstack-utils-2013.1-8.el6.noarch.rpm

How reproducible:
always

Steps to Reproduce:
$ openstack-status

(I have running services)


Actual results:
You see nothing about neutron or quantum.

Expected results:

See all neutron agent's status.

Additional info:
Including the 
$ neutron agent-list
output for remote agents would be a nice addition.
Comment 1 Mohammed Arafa 2013-09-14 23:08:31 EDT
is this a duplicate of bug 999507?
Comment 2 Pádraig Brady 2013-09-18 09:06:42 EDT

*** This bug has been marked as a duplicate of bug 999507 ***

Note You need to log in before you can comment on or make changes to this bug.