Bug 100793 - Excessive memory usage with default tcltk packages
Summary: Excessive memory usage with default tcltk packages
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 9
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
: 128746 (view as bug list)
Depends On:
Blocks: 113746
TreeView+ depends on / blocked
 
Reported: 2003-07-25 15:26 UTC by Richard Frederiksen
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-26 07:38:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Frederiksen 2003-07-25 15:26:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
Excessive memory usage can occur when running  a tcltk app with the version of
tcltk installed by default on Redhat 9.

We've seen increases in memory usage for some of our tcltk apps of two orders of
magnitude (8MB to 800MB). In some cases the excessive use of swap space makes
the machine essentially unresponsive.

If we uninstall the default tcltk packages (rpm --erase) and reinstall the same
version of tcltk from tarballs, the memory usage returns to normal.

This website has a possible explanation of the problem
(http://www.interlink.com.au/anthony/tech/rh9-tcltk/).

Version-Release number of selected component (if applicable):
tcltk-8.3.5-88

How reproducible:
Always

Steps to Reproduce:
1. Run a medium size tcltk app with the default tcltk rpms
2. Now remove the default rpms and run the app with tcltk installed from tarballs
3. Memory usage can differ by as much as two orders of magnitude.
    

Actual Results:  Memory usage increases by up to two orders of magnitude with
default tcltk rpms.

Expected Results:  Only a small change in memory usage.

Additional info:

Comment 1 Jens Petersen 2003-07-26 07:38:17 UTC
Thanks for the report.  Yes, I think this is currently "fixed" in rawhide
since I reverted the change to ucs4 there for the time being.

[This change was made rather late in the RHL9 development cycle for compatibility
with python through tkinter.  However it seems to have done more damage than
good. :-(  It seems we were mistaken in thinking Tcl/Tk could be configured easily
for ucs4...]

Comment 2 Jens Petersen 2004-08-13 12:31:16 UTC
*** Bug 128746 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.