Bug 128746 - memory usage bug in wish in tk8.3.5
Summary: memory usage bug in wish in tk8.3.5
Status: CLOSED DUPLICATE of bug 100793
Alias: None
Product: Fedora
Classification: Fedora
Component: tcltk   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-28 22:00 UTC by Neal Nuckolls
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neal Nuckolls 2004-07-28 22:00:29 UTC
Description of problem:
Start "wish" on RedHat 7.3 (tk8.3.3) and "ps -gaxl" shows
it's using around 2Mbytes resident.  ok.
Start "wish" on RedHat 9.0 (tk8.3.5) and "ps -gaxl" shows
it's using around 20Mbytes .

I used tkdiff a lot and when I ran it after installing
the tcl/tk in RedHat-9.0 it would use up 60-70 Mbytes (!)
of RSS, swapping everything else out, when viewing a large
source file.  Downgrading my tcl/tk to 8.3.3 and everything
is fine again.  I could not find an 8.4.x tcl/tcl RPM handy
so have not tested it.

Version-Release number of selected component (if applicable):

tk8.3.5
How reproducible:
completely.

Steps to Reproduce:
See above.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jens Petersen 2004-08-05 13:31:37 UTC
This sounds a bit like bug 100793, but the ucs4 patch for tcltk
is disabled in the RHEL3 update... so it can't be that.

Comment 2 Jens Petersen 2004-08-06 08:15:12 UTC
What exact tcltk package version and release are you using?

Comment 3 Neal Nuckolls 2004-08-13 00:39:25 UTC
tcl-8.3.5-88.i386.rpm and tk-8.3.5-88.i386.rpm ,
the ones that came in RedHat 9.0 .

Comment 4 Jens Petersen 2004-08-13 12:31:08 UTC
Then you, I'm sorry, but you shouldn't file against RHEL3 U3-beta. ;-)

RHL 9.0 is no longer supported.  If you're using RHEL please upgrade
to the tcltk packages there, otherwise I suggest upgrading to Rawhide.
Fedora Legacy may also be able to help support 9.0 still.

If you can't upgrade, try rebuilding the RHEL3 tcltk package on
9.0 and if you still have problems please reopen this bug.

*** This bug has been marked as a duplicate of 100793 ***

Comment 5 Red Hat Bugzilla 2006-02-21 19:04:45 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.