Bug 1008043 - drupal sql errors after 2.0.33 migration.
drupal sql errors after 2.0.33 migration.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
: 1007779 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-13 19:55 EDT by Wesley Hearn
Modified: 2015-05-14 19:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:51:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
broker log (34.22 KB, text/plain)
2013-09-16 06:05 EDT, Xiaoli Tian
no flags Details

  None (edit)
Description Wesley Hearn 2013-09-13 19:55:13 EDT
Description of problem:
After migration for the 2.0.33 release drupal is unable to connect to SQL with the following error:

PDOException: SQLSTATE[42000]: Syntax error or access violation: 1286 Unknown table engine 'InnoDB': SELECT expire, value FROM {semaphore} WHERE name = :name; Array ( [:name] => variable_init ) in lock_may_be_available() (line 167 of /var/lib/openshift/52336d03dbd93cd67e00017c/app-root/data/downloads/drupal-7.23/includes/lock.inc).

Version-Release number of selected component (if applicable):
openshift-origin-cartridge-php-0.9.3-1.el6oso.noarch
openshift-origin-cartridge-mysql-0.8.4-1.el6oso.noarch
rubygem-openshift-origin-node-1.14.7-1.el6oso.noarch
rhc-node-1.14.6-1.el6oso.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a drupal application with rhc app create drupal2 cron php-5.3 -k mysql-5 --from-code=https://github.com/openshift/drupal-quickstart.git
2. Migrate from 2.0.32 to 2.0.33
3. Try going to the application

Actual results:
Drupal fails with a HTTP 500 error and it shows SQL connection errors

Expected results:
It to display drupal

Additional info:
Comment 1 Xiaoli Tian 2013-09-16 05:12:32 EDT
Some errors in mysql log:
130916  3:20:13  InnoDB: Initializing buffer pool, size = 16.0M
130916  3:20:13  InnoDB: Completed initialization of buffer pool
InnoDB: Error: log file ./ib_logfile0 is of different size 0 5242880 bytes
InnoDB: than specified in the .cnf file 0 8388608 bytes!
130916  3:20:13 [ERROR] Plugin 'InnoDB' init function returned error.
130916  3:20:13 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
130916  3:20:13 [Note] Event Scheduler: Loaded 0 events
130916  3:20:13 [Note] /usr/libexec/mysqld: ready for connections.
Version: '5.1.69'  socket: '/var/lib/openshift/5236a5ee41c5cf0aa0000033/mysql//socket/mysql.sock'  port: 3306  Source distribution
Comment 2 Xiaoli Tian 2013-09-16 05:23:37 EDT
Seems related to this change:
 https://github.com/openshift/origin-server/pull/3599/
Comment 3 Xiaoli Tian 2013-09-16 05:29:23 EDT
If change the following line back to 5M in mysql/conf/my.cnf.erb.hidden file and restart the app, the migrated drupal app will be back to normal.

 innodb_log_file_size = <%= ENV['OPENSHIFT_APP_DNS'] == ENV['OPENSHIFT_GEAR_DNS'] ? 5 : 24 %>M
Comment 4 Xiaoli Tian 2013-09-16 06:05:26 EDT
Created attachment 798200 [details]
broker log

If leave the log size unchanged for the existing app, but set the storage engine env, mysql and the app failed to restart after setting it, broker log is attached, not sure if it's a related bug.

[root@ip-10-179-2-148 conf]# rhc env set OPENSHIFT_MYSQL_DEFAULT_STORAGE_ENGINE=innodb -a drupalapp
Setting environment variable(s) ... done
[root@ip-10-179-2-148 conf]# rhc cartridge-restart -c mysql-5.1 -a drupalapp
Restarting mysql-5.1 ... 
Unable to complete the requested operation due to: Failed to correctly execute all parallel operations.
Reference ID: fc96d4a8fb56672dca3bb20b12345b0d
Comment 5 Dan McPherson 2013-09-16 11:27:08 EDT
Fix pushed with:

https://github.com/openshift/origin-server/commit/6b9312228370b54fd26aeadd1721d5f2e70e82f1

Will be in devenv-stage_474
Comment 6 Dan McPherson 2013-09-16 11:27:28 EDT
Fix pushed with:

https://github.com/openshift/origin-server/commit/6b9312228370b54fd26aeadd1721d5f2e70e82f1

Will be in devenv-stage_474
Comment 7 Vojtech Vitek 2013-09-16 12:38:32 EDT
*** Bug 1007779 has been marked as a duplicate of this bug. ***
Comment 8 chunchen 2013-09-16 22:46:42 EDT
It's fixed, verified on devenv_stage_465 to devenv_stage_475.

Note You need to log in before you can comment on or make changes to this bug.