Bug 1008080 - Provide a Maven BOM containing all supported artifacts
Provide a Maven BOM containing all supported artifacts
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: EAP 6.2.0
Assigned To: Paul Gier
Nikoleta Ziakova
Russell Dickenson
:
: 1006454 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-14 09:34 EDT by Paul Gier
Modified: 2013-12-15 11:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:18:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gier 2013-09-14 09:34:32 EDT
We need a Maven BOM (Bill of Materials) which provides a list of all supported EAP Maven artifacts.  This BOM should be updated with each EAP release, and should use a version matching the target customer release (e.g. 6.2.0.GA).
Comment 1 Paul Gier 2013-09-17 15:50:32 EDT
The new BOM is available in the maven repo
It has a GAV of org.jboss.bom:eap6-supported-artifacts:6.2.0.Beta1
There is some documentation is in docspace:
https://docspace.corp.redhat.com/docs/DOC-156072
Comment 2 Nikoleta Ziakova 2013-09-18 06:10:30 EDT
BOM org.jboss.bom:eap6-supported-artifacts:6.2.0.Beta1 is not present in EAP 6.2.0 ER2 Maven repo zip
Comment 3 Paul Gier 2013-09-18 09:16:33 EDT
Looks like this was a problem in the Jenkins build config.  The zip was created before the new BOM was added.  I'll upload a new Maven repo zip (ER2.1) which includes the BOM.
Comment 4 Petr Sakař 2013-09-18 11:02:53 EDT
the org/jboss/bom/eap6-supported-artifacts/6.2.0.Beta1/eap6-supported-artifacts-6.2.0.Beta1.pom contains wrong dependency 

      <dependency>
        <groupId>sun.jdk</groupId>
        <artifactId>jconsole</artifactId>
        <version>jdk</version>
      </dependency>
Comment 5 Paul Gier 2013-09-18 13:19:24 EDT
Moving to ON_QA since the updated Maven repo is now available.
Problems with the bom such as an incorrect dependency should be addressed in a new bz issue.
Comment 6 Petr Sakař 2013-09-18 16:06:11 EDT
the org/jboss/bom/eap6-supported-artifacts/6.2.0.Beta1/eap6-supported-artifacts-6.2.0.Beta1.pom contains unsupported dependencies


      <dependency>
        <groupId>com.sun</groupId>
        <artifactId>tools</artifactId>
        <version>1.6</version>
      </dependency>
      <dependency>
        <groupId>log4j</groupId>
        <artifactId>log4j</artifactId>
        <version>1.2.16</version>
      </dependency>
Comment 7 Nikoleta Ziakova 2013-09-24 05:02:02 EDT
Maven repo zip now contains the new BOM. For issues found see BZ 1011421.
Comment 11 Paul Gier 2013-10-16 16:34:14 EDT
*** Bug 1006454 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.