Bug 1006454 - Refactor BOM structure for EAP 6.2
Refactor BOM structure for EAP 6.2
Status: CLOSED DUPLICATE of bug 1008080
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Build (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER6
: EAP 6.2.0
Assigned To: Paul Gier
Pavel Jelinek
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 12:04 EDT by Paul Gier
Modified: 2013-10-16 16:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 16:34:14 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gier 2013-09-10 12:04:00 EDT
We have requirements from support and layered products to provide a more clear documentation distinguishing supported and unsupported artifacts in the Maven repository.  In addition, because of our process changes for EAP 6.2, it is necessary to provide an easy to use BOM for our customers which manages all supported dependencies.

To meet these requirements we need to change the structure of our current BOM (jboss component management) project, and provide documentation about using the new BOMs.
Comment 1 Rostislav Svoboda 2013-09-11 07:41:14 EDT
We have problems with test execution in ER1 because of it and versions in dependency management. We have to hack and patch testsuites - for example WS TS.

Proposing it as blocker.
Comment 2 Petr Sakař 2013-09-11 08:19:38 EDT
List of wrong versions in BOM including version found in distributed maven repo 

org.apache.cxf:cxf-api:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-bindings-coloc:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-bindings-object:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-bindings-soap:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-bindings-xml:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-core:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-databinding-aegis:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-databinding-jaxb:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-frontend-jaxws:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-frontend-simple:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-management:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-transports-http:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-transports-jms:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-transports-local:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-ws-addr:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-ws-mex:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-ws-policy:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-ws-rm:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-rt-ws-security:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-tools-common:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-tools-java2ws:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-tools-validator:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-tools-wsdlto-core:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-tools-wsdlto-databinding-jaxb:2.6.8.redhat-7 found  2.7.6
org.apache.cxf:cxf-tools-wsdlto-frontend-jaxws:2.6.8.redhat-7 found  2.7.6
org.apache.cxf.services.sts:cxf-services-sts-core:2.6.8.redhat-7 found  2.7.6
org.apache.cxf.xjcplugins:cxf-xjc-boolean:2.6.0.redhat-4 found  2.6.1
org.apache.cxf.xjcplugins:cxf-xjc-dv:2.6.0.redhat-4 found  2.6.1
org.apache.cxf.xjcplugins:cxf-xjc-ts:2.6.0.redhat-4 found  2.6.1
org.javassist:javassist:3.15.0-GA-redhat-2 found  3.18.1-GA
org.jboss.aesh:aesh:0.33.8.redhat-1 found  0.33.8
org.jboss.ejb3:jboss-ejb3-ext-api:2.0.0-redhat-2 found  2.1.0
org.jboss.hal:release-stream:1.5.7.Final-redhat-1 found  
org.jboss:jboss-dmr:1.1.6.Final-redhat-1 found  1.2.0.Final
org.jboss.modules:jboss-modules:1.2.2.Final-redhat-1 found  1.3.0.Beta4
org.jboss.remotingjmx:remoting-jmx:1.1.0.Final-redhat-1 found  1.1.1.CR1
org.jboss.resteasy:async-http-servlet-3.0:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-atom-provider:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-cdi:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-hibernatevalidator-provider:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-jackson-provider:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-jaxb-provider:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-jaxrs:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-jettison-provider:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-jsapi:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-multipart-provider:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.resteasy:resteasy-yaml-provider:2.3.6.Final-redhat-1 found  2.3.7.Final
org.jboss.shrinkwrap:shrinkwrap-api:1.0.0-redhat-2 found  1.1.2
org.jboss.shrinkwrap:shrinkwrap-impl-base:1.0.0-redhat-2 found  1.1.2
org.jboss.shrinkwrap:shrinkwrap-spi:1.0.0-redhat-2 found  1.1.2
org.jboss.ws.cxf:jbossws-cxf-client:4.1.4.Final-redhat-7 found  4.2.0.Final
org.jboss.ws.cxf:jbossws-cxf-factories:4.1.4.Final-redhat-7 found  4.2.0.Final
org.jboss.ws.cxf:jbossws-cxf-resources:4.1.4.Final-redhat-7 found  4.2.0.Final
org.jboss.ws.cxf:jbossws-cxf-server:4.1.4.Final-redhat-7 found  4.2.0.Final
org.jboss.ws.cxf:jbossws-cxf-transports-httpserver:4.1.4.Final-redhat-7 found  4.2.0.Final
org.opensaml:opensaml:2.5.3.redhat-2 found  2.5.3
org.opensaml:openws:1.4.4.redhat-2 found  1.4.4
xml-resolver:xml-resolver:1.2-redhat-4 found  1.2-redhat-3
Comment 6 Paul Gier 2013-10-14 09:59:53 EDT
This issue was meant just to track some work internal to productization, so it's probably not necessary to mark this as blocker.  There are other bzs which track the BOM changes which are visible to QA and to users.

Bug 1008080 describes the user visible changes.
Bug 1018843 has been created to update the docs around the new user BOM.
Comment 7 Paul Gier 2013-10-16 16:34:14 EDT
Closing this as a duplicate, because it's covered by the other issues.

*** This bug has been marked as a duplicate of bug 1008080 ***

Note You need to log in before you can comment on or make changes to this bug.