Bug 1008103 - [abrt] seamonkey-2.20-1.fc19: nsProfileLock::FatalSignalHandler: Process /usr/lib/seamonkey/seamonkey was killed by signal 11 (SIGSEGV)
[abrt] seamonkey-2.20-1.fc19: nsProfileLock::FatalSignalHandler: Process /usr...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: seamonkey (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
abrt_hash:2b76ef1eeb3a873a798a6d09863...
:
: 1027508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-14 14:35 EDT by RcCharles
Modified: 2013-12-11 12:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 12:12:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (187.52 KB, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details
File: cgroup (140 bytes, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details
File: core_backtrace (29.51 KB, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details
File: dso_list (14.39 KB, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details
File: environ (1.32 KB, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details
File: maps (47.10 KB, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details
File: open_fds (3.39 KB, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details
File: proc_pid_status (797 bytes, text/plain)
2013-09-14 14:36 EDT, RcCharles
no flags Details

  None (edit)
Description RcCharles 2013-09-14 14:35:42 EDT
Description of problem:
I started seamonkey email client. I created new email user to access verizon.net. I clicked on my inbox.  Crashed will trying to download email.  I tried different parameters for pop3 account.  Crashed with different parameters.

Version-Release number of selected component:
seamonkey-2.20-1.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/lib/seamonkey/seamonkey -mail
crash_function: nsProfileLock::FatalSignalHandler
executable:     /usr/lib/seamonkey/seamonkey
kernel:         3.10.11-200.fc19.i686
runlevel:       N 5
uid:            1000
var_log_messages: Sep 14 13:06:57 localhost abrt[7378]: Saved core dump of pid 7291 (/usr/lib/seamonkey/seamonkey) to /var/tmp/abrt/ccpp-2013-09-14-13:06:44-7291 (326447104 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 nsProfileLock::FatalSignalHandler at /usr/src/debug/seamonkey-2.20/comm-release/objdir/mozilla/toolkit/profile/nsProfileLock.cpp:180
 #4 nsTreeRows::FindByResource at /usr/src/debug/seamonkey-2.20/comm-release/mozilla/content/xul/templates/src/nsTreeRows.cpp:157
 #5 nsXULTreeBuilder::HasGeneratedContent at /usr/src/debug/seamonkey-2.20/comm-release/mozilla/content/xul/templates/src/nsXULTreeBuilder.cpp:1059
 #6 nsContentTestNode::Constrain at /usr/src/debug/seamonkey-2.20/comm-release/mozilla/content/xul/templates/src/nsContentTestNode.cpp:79
 #7 TestNode::Constrain at /usr/src/debug/seamonkey-2.20/comm-release/mozilla/content/xul/templates/src/nsRuleNetwork.cpp:377
 #8 nsXULTemplateQueryProcessorRDF::Propagate at /usr/src/debug/seamonkey-2.20/comm-release/mozilla/content/xul/templates/src/nsXULTemplateQueryProcessorRDF.cpp:940
 #9 nsXULTemplateQueryProcessorRDF::OnAssert at /usr/src/debug/seamonkey-2.20/comm-release/mozilla/content/xul/templates/src/nsXULTemplateQueryProcessorRDF.cpp:769
 #10 CompositeDataSourceImpl::OnAssert at /usr/src/debug/seamonkey-2.20/comm-release/mozilla/rdf/base/src/nsCompositeDataSource.cpp:1263
 #11 nsMsgRDFDataSource::assertEnumFunc at /usr/src/debug/seamonkey-2.20/comm-release/mailnews/base/src/nsMsgRDFDataSource.cpp:345
 #12 nsCOMArray_base::EnumerateForwards at /usr/src/debug/seamonkey-2.20/comm-release/objdir/mozilla/xpcom/build/nsCOMArray.cpp:76
Comment 1 RcCharles 2013-09-14 14:36:02 EDT
Created attachment 797682 [details]
File: backtrace
Comment 2 RcCharles 2013-09-14 14:36:06 EDT
Created attachment 797683 [details]
File: cgroup
Comment 3 RcCharles 2013-09-14 14:36:12 EDT
Created attachment 797684 [details]
File: core_backtrace
Comment 4 RcCharles 2013-09-14 14:36:17 EDT
Created attachment 797685 [details]
File: dso_list
Comment 5 RcCharles 2013-09-14 14:36:21 EDT
Created attachment 797686 [details]
File: environ
Comment 6 RcCharles 2013-09-14 14:36:25 EDT
Created attachment 797687 [details]
File: limits
Comment 7 RcCharles 2013-09-14 14:36:32 EDT
Created attachment 797688 [details]
File: maps
Comment 8 RcCharles 2013-09-14 14:36:36 EDT
Created attachment 797689 [details]
File: open_fds
Comment 9 RcCharles 2013-09-14 14:36:40 EDT
Created attachment 797690 [details]
File: proc_pid_status
Comment 10 Dmitry Butskoy 2013-09-14 15:57:14 EDT
According to backtrace function names, it looks like old known issue "crash when starts with a locked seamonkey profile" (still not fixed upstream :( ).

Try to perform the same things under a clean profile (a new user, or remove/rename ~/.mozilla subdir etc...)
Comment 11 Dmitry Butskoy 2013-11-07 14:19:29 EST
*** Bug 1027508 has been marked as a duplicate of this bug. ***
Comment 12 Martin Stransky 2013-12-11 12:12:19 EST
This is an automatic bug processing. If you can reproduce the crash (or see it regularly) please reopen the bug and remove [abrt] from the subject. Thanks!

Note You need to log in before you can comment on or make changes to this bug.