Bug 1008227 - SSD cache
SSD cache
Status: CLOSED UPSTREAM
Product: Fedora Documentation
Classification: Fedora
Component: storage-administration-guide (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pete Travis
Fedora Docs QA
: Tracking
Depends On: 1003208 998543 999690 1000078 1000817 1001120 1003207
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-15 15:28 EDT by Pete Travis
Modified: 2017-08-31 15:59 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 998543
Environment:
Last Closed: 2017-08-31 15:59:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Travis 2013-09-15 15:28:38 EDT
+++ This bug was initially created as a clone of Bug #998543 +++

This is a tracking bug for Change: SSD cache
For more details, see: http://fedoraproject.org//wiki/Changes/SSD_cache

Using recent kernel (3.9 and later) features for (fast) SSD caching of (slow) ordinary hard disks.

--- Additional comment from Rolf Fokkens on 2013-08-21 13:35:33 EDT ---

I'll build a bcache-tools RPM and a dm-cache-utils rpm (actually bcache-tools is already available here: bcache-tools-20130820-0.1.fc19.src.rpm).

I'll follow the procedure as described here: https://fedoraproject.org/wiki/Join_the_package_collection_maintainers

--- Additional comment from Rolf Fokkens on 2013-08-24 11:51:34 EDT ---

Tried to create a dmcache-utils package as well (Bug 1000078) but it doesn't look really useful. So I'll focus on bcache-tools first. For that I still need a sponsor.

--- Additional comment from Rolf Fokkens on 2013-08-27 06:52:40 EDT ---

I closed Bug 1000078 since good userland support requires LVM2 to support dm-cache. Which will happen 'in the future', but F20 doesn't look feasible to me.

--- Additional comment from Rolf Fokkens on 2013-08-31 16:21:30 EDT ---

Create Bug 1003207 (bcache support for dracut) which is not blocking for F20, but probably will be blocking for F21.

--- Additional comment from Rolf Fokkens on 2013-08-31 16:25:06 EDT ---

Create Bug 1003208 (bcache support for anaconda) which is not blocking for F20, but probably will be blocking for F21.

--- Additional comment from Rolf Fokkens on 2013-09-09 04:18:18 EDT ---

Test day planned: https://fedorahosted.org/fedora-qa/ticket/415

--------------------------------------------------------------
Discussion at https://lists.fedoraproject.org/pipermail/devel/2013-July/185336.html

Please assess existing documentation for the impact of this Change.
Comment 1 Pete Travis 2014-01-26 17:30:28 EST
The Storage guide seems like a fitting place to document bcache, reassigning there.
Comment 2 Pete Travis 2017-08-31 15:59:00 EDT
Issues for this guide have moved to pagure, I have created https://pagure.io/storage-administration-guide/issue/3 to track.

Note You need to log in before you can comment on or make changes to this bug.