Bug 998543 - SSD cache
SSD cache
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Changes Tracking (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
: Tracking
Depends On: 1003208 999690 1000078 1000817 1001120 1003207 1004693
Blocks: 1008227 1008228
  Show dependency treegraph
 
Reported: 2013-08-19 09:44 EDT by Jaroslav Reznik
Modified: 2013-12-18 09:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1008227 1008228 (view as bug list)
Environment:
Last Closed: 2013-12-18 09:00:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2013-08-19 09:44:45 EDT
This is a tracking bug for Change: SSD cache
For more details, see: http://fedoraproject.org//wiki/Changes/SSD_cache

Using recent kernel (3.9 and later) features for (fast) SSD caching of (slow) ordinary hard disks.
Comment 1 Rolf Fokkens 2013-08-21 13:35:33 EDT
I'll build a bcache-tools RPM and a dm-cache-utils rpm (actually bcache-tools is already available here: bcache-tools-20130820-0.1.fc19.src.rpm).

I'll follow the procedure as described here: https://fedoraproject.org/wiki/Join_the_package_collection_maintainers
Comment 2 Rolf Fokkens 2013-08-24 11:51:34 EDT
Tried to create a dmcache-utils package as well (Bug 1000078) but it doesn't look really useful. So I'll focus on bcache-tools first. For that I still need a sponsor.
Comment 3 Rolf Fokkens 2013-08-27 06:52:40 EDT
I closed Bug 1000078 since good userland support requires LVM2 to support dm-cache. Which will happen 'in the future', but F20 doesn't look feasible to me.
Comment 4 Rolf Fokkens 2013-08-31 16:21:30 EDT
Create Bug 1003207 (bcache support for dracut) which is not blocking for F20, but probably will be blocking for F21.
Comment 5 Rolf Fokkens 2013-08-31 16:25:06 EDT
Create Bug 1003208 (bcache support for anaconda) which is not blocking for F20, but probably will be blocking for F21.
Comment 6 Rolf Fokkens 2013-09-09 04:18:18 EDT
Test day planned: https://fedorahosted.org/fedora-qa/ticket/415
Comment 7 Rolf Fokkens 2013-10-10 07:21:41 EDT
The Change is close to completion for F20:
- Bug 1004693 is ON_QA, and close to being Fixed
- Bug 1003208 is part of F21, not blocking for F20,
Comment 8 Jaroslav Reznik 2013-12-18 09:00:58 EST
Closing this bug as this Change was delivered in Fedora 20 release. Please, reopen in case of any issues you encounter regarding this Change completion.

Note You need to log in before you can comment on or make changes to this bug.