Bug 1008284 - Review Request: admesh - Diagnose and/or repair common problems with STL files
Review Request: admesh - Diagnose and/or repair common problems with STL files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1021919
  Show dependency treegraph
 
Reported: 2013-09-16 01:19 EDT by John C Peterson
Modified: 2014-10-09 15:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-28 09:16:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mhroncok: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description John C Peterson 2013-09-16 01:19:24 EDT
Spec URL: http://www.eskimo.com/~jcp/admesh.spec
SRPM URL: http://www.eskimo.com/~jcp/admesh-0.95-1.fc19.src.rpm

Description: ADMesh is a program for diagnosing and/or repairing commonly encountered problems with STL (STereo Lithography) data files. It can remove degenerate and unconnected facets, connect nearby facets, fill holes by adding facets, and repair facet normals. Simple transformations such as scaling, translation and rotation are also supported. ADMesh can read both ASCII and binary format STL files, while the output can be in AutoCAD DXF, Geomview OFF, STL, or VRML format.

Notes: Licensed under GPLv2. This package is a candidate for the existing 3D Printing Feature. 

Fedora Account System Username: jcp
Comment 1 Susi Lehtola 2013-09-24 15:13:14 EDT
IMHO you need to open the STL abbreviation in the summary.
Comment 2 John C Peterson 2013-09-28 13:15:18 EDT
That's not a bad idea.

I will expand STL to STereo Lithography in the summary of the next release...
Comment 3 Miro Hrončok 2013-10-19 10:48:48 EDT
Be sure to pass %{?_smp_mflags} to make.
I believe that install command with -D doesn't require to use mkdir before.
Comment 4 Miro Hrončok 2013-10-19 10:55:38 EDT
Any chance to provide also a library that can be used in other packages?

See this: https://github.com/kliment/simarrange
Comment 5 Miro Hrončok 2013-10-19 11:18:51 EDT
As it seems, it bundles getopt.

Be sure to run rm -f getopt* in %prep.
Comment 6 John C Peterson 2013-10-21 02:04:20 EDT
Spec URL: http://www.eskimo.com/~jcp/admesh.spec
SRPM URL: http://www.eskimo.com/~jcp/admesh-0.95-2.fc19.src.rpm

Hi Miro,

Thanks for taking time to review my package.

This release should address the comments and issues raised so far.

I put in the "rm -f getopt*" in the prep section just to be safe. I think the configure script decides if the bundled getopt is used or not (and it was not for me).

Anyhow, while checking on that, I noticed that the linking of admesh from the objects was being done without the "-g" flag. The Makefile is a bit broken as LDFLAGS is not included in the link statement. One could patch the Makefile, but I decided on a work around by defining CC = "gcc -g" which works as intended. Fortunately, the build process is fairly trivial...

Thanks for the "heads up" on simarrange. The admesh code in that git repo is almost identical to the upstream tarball. An inspection of simarrange.c shows that some of the functions in admesh are being used. Some sort of library might be a possibility. I will think about it some more...
Comment 7 Miro Hrončok 2013-10-21 08:28:47 EDT
I was kind of impatient  and started working on a "fork" of admesh, that sorts out my and others problems.

https://github.com/scarabeusiv/admesh

It provides a lib. It has import string. It also fixes some weird behavior. I'm also working on a proper manpage. Considering admesh is from 1996, it's not a much living project, but I'll let the author know, assuming he is still gettiung emails on the old address.
Comment 8 Miro Hrončok 2013-10-21 11:59:36 EDT
Here you are:

https://github.com/scarabeusiv/admesh/releases
Comment 9 John C Peterson 2013-10-22 03:11:11 EDT
Spec URL: http://www.eskimo.com/~jcp/admesh.spec
SRPM URL: http://www.eskimo.com/~jcp/admesh-0.95-3.fc19.src.rpm

Good stuff Miro! I have not seen some of those patches myself.

The latest spec file still feels a bit rough, but it's working well with the new upstream code.

A couple thoughts come to mind regarding your fork;

If you have time and are so inclined, how about bindings of the admesh library to Perl, Python etc. generated using swig? I just tried running swig on an interface file that just included the stl.h header and got no complaints from swig. I didn't have much time to examine the generated interface.

It would be great if Andreea's Master's Thesis could be included in the documentation in PDF format (The copy on his website is in Word format, see: http://www.varlog.com/admesh-htm/ADMeshThesis.zip). There are probably some dangling copyright issues with that, but might be easy to fix if you get into contact with Andreea.
Comment 10 Miro Hrončok 2013-10-22 04:46:55 EDT
Changelog entry has a different version. Also if this is the first spec with 0.97.2, I suppose the release number should be 1 again. The SRPM link says 0.95-3, but spec is 0.97.2-3.

Use %{make_install} over make DESTDIR=%{buildroot} install (optional, but looks better, does the same).

Consider subpackage admesh-lib, so other packages depending on it will not pull the app. But the app is small and make no mess, so this is also not a must thing.

===========================

Now to your questions. A. Martin (whatever his/her first name is) is not responding. Unless somehow confirmed that the thesis is available under GPL or other Fedora compatible license, we cannot ship it. I will also not put it to the app tarball, as you would then need to strip it before putting it into SRPM/git and that't a pain.

I made this repository to avoid bundling and patching this project in other projects, as it would make packagers life hell. When I was in, I've tried to pull in whatever fix possible. I plan to maintain the code and accept patches that won't break backward compatibility and keep the code pure C without warnings.

If you want to create Perl and/or Python bindings, I'm happy to include it, as long as it meets the rules described. But I will definitely not do it just because I'm bored (and believe me, I'm not). I invested my time into this, to save it in the future :)

Feel free to start a discussion about this on GitHub Issues so we can keep this bug about the package.
Comment 11 John C Peterson 2013-10-23 01:33:26 EDT
Spec URL: http://www.eskimo.com/~jcp/admesh.spec
SRPM URL: http://www.eskimo.com/~jcp/admesh-0.97.2-1.fc19.src.rpm

Hi Miro,

Sorry for the bad SRPM link on the last go around (my fault).

I reset the release number back to 1 as you suggested. I removed some of my changelog entries that only applied to the old sources (they didn't make much sense after the change over, so it seemed best to just remove them).

I also created a libs subpackage and fixed the package requirements.

The thesis document is very useful information, so I created a README.Fedora file that provides the URL for end users (so they can fetch it themselves).

P.S. I'm pretty sure the original author Andreea Martin is male. (He identifies himself as Anthony Martin is the copyright notices in the source code).

P.P.S I will put the Perl, Python bindings for upstream on my TODO list...
Comment 12 Miro Hrončok 2013-10-23 08:01:44 EDT
Each %changelog entry now has - 0.95-1
Comment 13 John C Peterson 2013-10-23 13:26:02 EDT
I don't have any strong feelings one way or another, but the wiki states that multiple entries are OK if the package has not been built yet.

https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#Multiple_Changelog_Entries_per_Release
Comment 14 Miro Hrončok 2013-10-23 14:48:10 EDT
But it should be 0.97.2-1, right?
Comment 15 Miro Hrončok 2013-10-23 14:49:17 EDT
%post and %postun should go to libs subpackage
Comment 16 John C Peterson 2013-10-23 14:59:36 EDT
Spec URL: http://www.eskimo.com/~jcp/admesh.spec
SRPM URL: http://www.eskimo.com/~jcp/admesh-0.97.2-1.fc19.src.rpm

OK, trying to juggle too many things when I first read C#12.

Fixed the bad version numbers in the changelog.

%post and %postun are now restricted to the libs subpackage.
Comment 17 Miro Hrončok 2013-10-23 16:06:36 EDT
Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated

===== FAILS =====

[!]: License field in the package spec file matches the actual license.
     This is clearly GPLv2+, not just GPLv2. All sources include "or any later version" clause

[!]: License file installed when any subpackage combination is installed.
     If you install -libs, you don't get it.

[!]: Requires correct, justified where necessary.
     devel package should require libs, not the main package

[!]: admesh.src:12: W: mixed-use-of-spaces-and-tabs (spaces: line 2, tab: line 12)

===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Header files in -devel subpackage, if present.
[x]: ldconfig called in %post and %postun if required.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[!]: License field in the package spec file matches the actual license.
[!]: License file installed when any subpackage combination is installed.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[!]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 71680 bytes in 7 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
     Except already mentioned thing
[-]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in admesh-libs
     Doesn't work that way here
[x]: Package functions as described.
[x]: Latest version is packaged.
[-]: Package does not include license text files separate from upstream.
[x]: Scriptlets must be sane, if used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[?]: Package should compile and build into binary rpms on all supported
     architectures.
     Didn't test
[-]: %check is present and all tests pass.
[-]: Packages should try to preserve timestamps of original installed files.
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: The placement of pkgconfig(.pc) files are correct.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[-]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: admesh-0.97.2-1.fc18.x86_64.rpm
          admesh-devel-0.97.2-1.fc18.x86_64.rpm
          admesh-libs-0.97.2-1.fc18.x86_64.rpm
          admesh-0.97.2-1.fc18.src.rpm
admesh.x86_64: W: spelling-error %description -l en_US normals -> normal, normal's, formals
False positive.

admesh-devel.x86_64: W: no-documentation
Not needed.

admesh-libs.x86_64: W: spelling-error Summary(en_US) Runtime -> Run time, Run-time, Rudiment
False positive.

admesh-libs.x86_64: W: spelling-error %description -l en_US runtime -> run time, run-time, rudiment
False positive.

admesh-libs.x86_64: W: shared-lib-calls-exit /usr/lib64/libadmesh.so.1.0.0 exit@GLIBC_2.2.5
That's how it is upstream. Might get fixed in the future.'

admesh-libs.x86_64: W: no-documentation
Should have COPYING, already mentioned.

admesh.src: W: spelling-error %description -l en_US normals -> normal, normal's, formals
False positive.

admesh.src:12: W: mixed-use-of-spaces-and-tabs (spaces: line 2, tab: line 12)
Fix that.

admesh.src: W: invalid-url Source0: http://github.com/hroncok/admesh/releases/download/v0.97.2/admesh-0.97.2.tar.gz HTTP Error 403: Forbidden
False positive.

4 packages and 0 specfiles checked; 0 errors, 9 warnings.

Requires
--------
admesh (rpmlib, GLIBC filtered):
    admesh-libs(x86-64)
    libadmesh.so.1()(64bit)
    libc.so.6()(64bit)
    rtld(GNU_HASH)

admesh-libs (rpmlib, GLIBC filtered):
    /sbin/ldconfig
    libc.so.6()(64bit)
    libm.so.6()(64bit)
    rtld(GNU_HASH)

admesh-devel (rpmlib, GLIBC filtered):
    /usr/bin/pkg-config
    admesh(x86-64)
    libadmesh.so.1()(64bit)

Provides
--------
admesh:
    admesh
    admesh(x86-64)

admesh-libs:
    admesh-libs
    admesh-libs(x86-64)
    libadmesh.so.1()(64bit)

admesh-devel:
    admesh-devel
    admesh-devel(x86-64)
    pkgconfig(libadmesh)



Source checksums
----------------
http://github.com/hroncok/admesh/releases/download/v0.97.2/admesh-0.97.2.tar.gz :
  CHECKSUM(SHA256) this package     : 388361a83918d3a608463bba1b57d5c5edb2eff50be28067da8b44da23d65664
  CHECKSUM(SHA256) upstream package : 388361a83918d3a608463bba1b57d5c5edb2eff50be28067da8b44da23d65664


Generated by fedora-review 0.4.0 (eaf16cd) last change: 2013-05-30
Command line :./try-fedora-review -b 1008284
Buildroot used: fedora-18-x86_64
Active plugins: Generic, Shell-api, C/C++
Disabled plugins: Java, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG


Package is not yet approved.
Comment 18 John C Peterson 2013-10-24 03:00:46 EDT
Spec URL: http://www.eskimo.com/~jcp/admesh.spec
SRPM URL: http://www.eskimo.com/~jcp/admesh-0.97.2-1.fc19.src.rpm

This should fix the issues raised. Should be close if not there...

Scratch rawhide build to check for arch specific problems: http://koji.fedoraproject.org/koji/taskinfo?taskID=6092723
Comment 19 Miro Hrončok 2013-10-24 06:12:13 EDT
APPROVED
Comment 20 John C Peterson 2013-10-25 02:41:49 EDT
New Package SCM Request
=======================
Package Name: admesh
Short Description: Diagnose and/or repair problems with STereo Lithography files
Owners: jcp
Branches: f18 f19 f20 el6
InitialCC:
Comment 21 Gwyn Ciesla 2013-10-25 07:56:10 EDT
Git done (by process-git-requests).
Comment 22 Fedora Update System 2013-10-26 13:29:57 EDT
admesh-0.97.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/admesh-0.97.2-1.fc20
Comment 23 Fedora Update System 2013-10-26 13:32:01 EDT
admesh-0.97.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/admesh-0.97.2-1.fc19
Comment 24 Fedora Update System 2013-10-26 13:33:33 EDT
admesh-0.97.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/admesh-0.97.2-1.fc18
Comment 25 Fedora Update System 2013-10-26 13:35:03 EDT
admesh-0.97.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/admesh-0.97.2-1.el6
Comment 26 Fedora Update System 2013-11-04 21:56:03 EST
admesh-0.97.2-1.fc18 has been pushed to the Fedora 18 stable repository.
Comment 27 Fedora Update System 2013-11-04 22:00:47 EST
admesh-0.97.2-1.fc19 has been pushed to the Fedora 19 stable repository.
Comment 28 Fedora Update System 2013-11-10 02:15:36 EST
admesh-0.97.2-1.fc20 has been pushed to the Fedora 20 stable repository.
Comment 29 Fedora Update System 2013-11-13 13:49:19 EST
admesh-0.97.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.
Comment 30 Fedora Update System 2014-09-23 11:08:35 EDT
admesh-0.98.1-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/admesh-0.98.1-1.el7
Comment 31 Fedora Update System 2014-10-09 15:55:31 EDT
admesh-0.98.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository.

Note You need to log in before you can comment on or make changes to this bug.