Bug 1008290 - Cancelling a REST request triggers a failover event
Cancelling a REST request triggers a failover event
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.2
Assigned To: Matthew Casperson
:
Depends On:
Blocks: 1013825
  Show dependency treegraph
 
Reported: 2013-09-16 01:44 EDT by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 19:49:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2013-09-16 01:44:25 EDT
When closing a page with pending REST requests, a failover event is triggered because the REST request is cancelled.

This should be handled better.
Comment 1 Matthew Casperson 2013-10-01 19:40:11 EDT
Fixed in 201310020921

I couldn't actually replicate this behaviour in Chrome 28 or Firefox 24.

I did add a check to prevent a flood of "Unable to find any servers to connect to. Please report this issue to your system administrator." errors. This can be tested by adding the line

1.1.1.1         topika.ecs.eng.bne.redhat.com

to /etc/hosts, and closing and reopening the web browser. Opening a page like /pressgang-ccms-ui-next/#SearchResultsAndTopicView;query;topicIds=3737 where multiple REST calls are initiated will show that the error message only appears once.

Note You need to log in before you can comment on or make changes to this bug.