Bug 1008367 - RHEV-H upgrade failed when run "ovirt-node-upgrade" command for the second time.
RHEV-H upgrade failed when run "ovirt-node-upgrade" command for the second time.
Status: CLOSED DUPLICATE of bug 1006390
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-16 05:26 EDT by cshao
Modified: 2013-09-17 08:58 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-17 08:58:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cshao 2013-09-16 05:26:06 EDT
Description of problem:
RHEV-H upgrade failed when run "ovirt-node-upgrade" command for the second time.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130725.0.auto1831.el6.iso
ovirt-node-3.0.1-999.0.20130913165928git1078b75.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhev-hypervisor6-6.5-20130725.0.auto1831.el6.iso
2. Run command "ovirt-node-upgrade --iso $ISONAME"
3. Run command "ovirt-node-upgrade --iso $ISONAME --reboot 5"
4. Focus on the output.

Actual results:
1. RHEV-H Upgrade Failed.
2. RHEV-H upgrade can successful after reboot the host.
====================================
# ovirt-node-upgrade --iso rhev-hypervisor6-6.4-20130815.0.auto778.el6_4.iso --reboot 5
ovirt-node-upgrade.UpgradeTool: INFO     Temporary Directory is: /data/tmp8dl3hL
ovirt-node-upgrade.LockFile: INFO     Acquiring Lock
ovirt-node-upgrade.UpgradeTool: INFO     Running pre-upgrade hooks
ovirt-node-upgrade.UpgradeTool: INFO     pre-upgrade hooks completed
ovirt-node-upgrade.UpgradeTool: INFO     hooks: False
ovirt-node-upgrade.UpgradeTool: INFO     Installing Bootloader
INFO:ovirt-node-upgrade.UpgradeTool:Installing Bootloader
ovirt-node-upgrade.UpgradeTool: ERROR    Error: Upgrade Failed: [Errno 30] Read-only file system: '/liveos/grub'
Traceback (most recent call last):
  File "/usr/sbin/ovirt-node-upgrade", line 343, in run
    self._run_upgrade()
  File "/usr/sbin/ovirt-node-upgrade", line 242, in _run_upgrade
    if not upgrade.ovirt_boot_setup():
  File "/usr/lib/python2.6/site-packages/ovirtnode/install.py", line 391, in ovirt_boot_setup
  File "/usr/lib64/python2.6/os.py", line 157, in makedirs
OSError: [Errno 30] Read-only file system: '/liveos/grub'
ERROR:ovirt-node-upgrade.UpgradeTool:Error: Upgrade Failed: [Errno 30] Read-only file system: '/liveos/grub'
Traceback (most recent call last):
  File "/usr/sbin/ovirt-node-upgrade", line 343, in run
    self._run_upgrade()
  File "/usr/sbin/ovirt-node-upgrade", line 242, in _run_upgrade
    if not upgrade.ovirt_boot_setup():
  File "/usr/lib/python2.6/site-packages/ovirtnode/install.py", line 391, in ovirt_boot_setup
  File "/usr/lib64/python2.6/os.py", line 157, in makedirs
OSError: [Errno 30] Read-only file system: '/liveos/grub'
ovirt-node-upgrade.UpgradeTool: INFO     Running rollback hooks
INFO:ovirt-node-upgrade.UpgradeTool:Running rollback hooks
ovirt-node-upgrade.UpgradeTool: INFO     rollback hooks completed
INFO:ovirt-node-upgrade.UpgradeTool:rollback hooks completed
ovirt-node-upgrade.UpgradeTool: INFO     Upgrade Failed, Rollback Completed
INFO:ovirt-node-upgrade.UpgradeTool:Upgrade Failed, Rollback Completed
ovirt-node-upgrade.UpgradeTool: INFO     Cleaning up temporary directory
INFO:ovirt-node-upgrade.UpgradeTool:Cleaning up temporary directory
DEBUG:ovirt-node-upgrade.UpgradeTool:('/bin/umount', '/data/tmp8dl3hL/rootfs')
DEBUG:ovirt-node-upgrade.UpgradeTool:[]
DEBUG:ovirt-node-upgrade.UpgradeTool:
DEBUG:ovirt-node-upgrade.UpgradeTool:('/bin/umount', '/data/tmp8dl3hL/squashfs')
DEBUG:ovirt-node-upgrade.UpgradeTool:[]
DEBUG:ovirt-node-upgrade.UpgradeTool:
DEBUG:ovirt-node-upgrade.UpgradeTool:('/bin/umount', '/live')
DEBUG:ovirt-node-upgrade.UpgradeTool:[]
DEBUG:ovirt-node-upgrade.UpgradeTool:


Expected results:
RHEV-H upgrade successful.

Additional info:
Comment 2 Joey Boggs 2013-09-17 08:58:40 EDT

*** This bug has been marked as a duplicate of bug 1006390 ***

Note You need to log in before you can comment on or make changes to this bug.