Bug 100858 - cancel in Advanced... mail search causes ja evolution to loop
Summary: cancel in Advanced... mail search causes ja evolution to loop
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-07-26 05:12 UTC by Jens Petersen
Modified: 2007-04-18 16:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-15 00:12:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace (12.89 KB, text/plain)
2003-07-26 07:24 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2003-07-26 05:12:34 UTC
Description of problem:
When evolution is run in a ja locale, and one press the Cancel button in the
the "Advanced..." search dialog, evolution goes into a hard loop grabbing most
of the cpu.

Version-Release number of selected component (if applicable):
evolution-1.4.3-5

How reproducible:
every time

Steps to Reproduce:
1. run "LANG=ja_JP.UTF-8 evolution"
2. menubar Search -> Advanced
3. press Cancel in dialog

Actual results:
evolution hang in a loop and can only be killed forcefully.

Expected results:
The dialog to display like it does in LANG=C say.

Additional info:
1. Cancel seems to be the only button causing this, the other buttons work ok
afaict.
2. I haven't tested this yet on a clean install, just my workstation.

Comment 1 Jens Petersen 2003-07-26 05:18:00 UTC
Sorry, Additional information 1 is inaccurate: it also hangs for me when the
other buttons (Save and OK) are pushed or if the dialog window is closed with
the window manager.

Comment 2 Jeremy Katz 2003-07-26 06:31:44 UTC
Can you attach with gdb and get a backtrace?

Comment 3 Jens Petersen 2003-07-26 07:07:07 UTC
Btw I just noticed a spew of the following warning appearing when it happens:

(evolution:2545): Gdk-CRITICAL **: file gdkwindow.c: line 526
(gdk_window_get_parent): assertion `GDK_IS_WINDOW (window)' failed


Comment 4 Jens Petersen 2003-07-26 07:24:18 UTC
Created attachment 93160 [details]
gdb backtrace

Comment 5 Akira TAGOH 2003-07-26 17:17:20 UTC
It looks like this bug in the upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=115077

Owen?


Note You need to log in before you can comment on or make changes to this bug.