Bug 100862 - default font quality decreased
Summary: default font quality decreased
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: fontconfig (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL: http://216.226.44.198/font-problem/
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-07-26 06:22 UTC by Klaasjan Brand
Modified: 2007-04-18 16:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-15 15:54:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Klaasjan Brand 2003-07-26 06:22:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030703 Galeon/1.3.6

Description of problem:
Something in the fonts or font rendering code has changed; the default Luxi font
family is rendered a bit off compared to Red Hat 9.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Just look at any application under X with the default desktop

Comment 1 Marc Deslauriers 2003-07-26 12:36:11 UTC
I agree. Something changed in the new freetype that makes Luxi look ugly.

I put up a web page with screenshots comparing rhl9 with severn here:

http://216.226.44.198/font-problem/

Comment 2 Owen Taylor 2003-09-02 23:18:47 UTC
THe "Here is Severn with bytecode interpreter turned on" screenshot
looks like you've somehow switched from "Best Shapes" to "Best Contrast"
in the font properties dialog.

(Note that having the bytecode interpreter turned on is a config we support)


Comment 3 Owen Taylor 2003-09-22 20:34:22 UTC
OK, I think I tracked this one down ... a mistake in the spec file
(or change in fontconfig's configure options) meant that the wrong
font directories were appearing in /etc/fonts/fonts.conf, so the
wrong version of Luxi Sans was used - TrueType instead of Type1.

(/usr/X11R6/lib/X11/fonts/TTF should not be in the list.)

With the TrueType bytecode interpreter, "Best Shapes" vs. "Best Contrast"
doesn't make a difference, so you got the ugly "Best Shapes" appearance.


Comment 4 Marc Deslauriers 2003-10-13 23:58:32 UTC
Removing /usr/X11R6/lib/X11/fonts/TTF from fonts.conf worked for me. Everything
is nice and clean. 

Can this be put in rawhide, please? 


Comment 5 Owen Taylor 2003-10-15 15:54:34 UTC
* Mon Sep 22 2003 Owen Taylor <otaylor@redhat.com> 2.2.1-6.0
- Should have been passing --with-add-fonts, not --with-add-dirs to
  configure ... caused wrong version of Luxi to be used. (#100862)




Note You need to log in before you can comment on or make changes to this bug.