Bug 100863 - GRUB returns error code 17 when trying to boot from ReiserFS filesystem
Summary: GRUB returns error code 17 when trying to boot from ReiserFS filesystem
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: grub (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: athlon Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-26 07:11 UTC by Justin Churchey
Modified: 2007-04-18 16:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-01 23:25:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Churchey 2003-07-26 07:11:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When trying to boot one of my other distributions that was installed on a
ReiserFS filesystem, GRUB returns and error saying that it cannot read the
filesystem.  

Taking ReiserFS support out of the kernel was one thing, but not giving GRUB the
ability to boot from a ReiserFS filesystem greatly hampers any interaction w/
other distros on the same machine.  Some of the more popular distros like Debian
and SuSE standardize on ReiserFS.  The least you could do was continue some form
of support for it.

Version-Release number of selected component (if applicable):
grub-0.93-6

How reproducible:
Always

Steps to Reproduce:
1.Boot Computer
2.Select Distro installed on ReiserFS (SuSE 8.2)
    

Actual Results:  GRUB returns Error Code 17 and refuses to mount the filesystem
to boot it.

Expected Results:  GRUB should boot the OS with no problem.  It is supposed to
be able to boot many different OS across different filesystems

Additional info:

Comment 1 Warren Togami 2003-09-21 11:39:01 UTC
http://mail.gnu.org/archive/html/bug-grub/2001-06/msg00134.html
Possibly related?

Did GRUB from an earlier version of Red Hat or other distributions successfully
boot a reiserfs fs?


Comment 2 Justin Churchey 2003-09-21 17:31:39 UTC
I've never had troubles booting previous versions of RH (since 7.3) from a
Resier filesystem.

Comment 3 Michael K. Johnson 2003-10-21 20:00:48 UTC
Installed to the MBR or the boot record of /boot?

Comment 4 Jeremy Katz 2003-10-21 21:57:37 UTC
And I just did an install to an all reiserfs system and was able to boot with
grub fine (grub installed to the mbr)

Comment 5 Justin Churchey 2003-10-21 23:18:29 UTC
I installed it on the first sector of /boot

Comment 6 Jeremy Katz 2003-10-22 16:59:23 UTC
Hrmm, and I've done this now and had it work as well.  Did this still happen
with test3?  If so, is it a large filesystem?

Comment 7 Warren Togami 2003-10-22 17:46:08 UTC
Does GRUB require notails with reiserfs?

Comment 8 Martin Ebourne 2003-11-05 15:08:19 UTC
I'm using FC test 3 with ReiserFS. I installed fresh on a new laptop
(as the only OS), initially ext3 because there was no option for
reiserfs (though I now know about the install boot option - never seen
it documented though).
Anyhow, I then converted the whole system over to ReiserFS by creating
a new partition and copying everything. Only thing I had to do was
mkinitrd to get the reiserfs module at boot time. My machine now is
pure ReiserFS and has been for a couple of weeks. Grub has always
worked fine.

Not saying there isn't a bug, just that it's more specific than just
using Reiser. I'm now fully updated to rawhide and all still fine.

Oh, and I don't use notails, so doubt that is it. (That is to say, I
do have tails packed, the default.)


Note You need to log in before you can comment on or make changes to this bug.