Bug 100865 - ReiserFS should continue to be Supported
ReiserFS should continue to be Supported
Status: CLOSED DUPLICATE of bug 100661
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
athlon Linux
high Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-26 03:30 EDT by Justin Churchey
Modified: 2007-03-27 00:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Churchey 2003-07-26 03:30:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
In previous versions of RH Linux, when it boots off the installation CD you
could pass the "reiserfs" parameter to the linux boot command and the kernel
would be ReiserFS enabled.  I could set mountpoints for the ReiserFS partitions
of my other distros, even share a /home partition b/t all three.

However, ReiserFS is not even an option in your kernel release.  My partitioning
was a hassle b/c of my inability to set mountpoints.  I cannot continue to share
my /home partition or swap files b/t distros b/c RH cannot interact with the
other filesystems.


Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1.Install the RH Kernel with anaconda

    

Actual Results:  Disk Druid is not able to work w/ ReiserFS partitions
Cannot read files in other OS b/c of inability to mount the filesystem.

Expected Results:  RH should continue support of popular filesystems.

Additional info:

ReiserFS is still in wide use by a lot of other *nix systems and linux distros.
 To take away ReiserFS support in your kernel build greatly hampers a users
ability to interact with another popular filesystem.  Linux was meant to be
highly customizable and the administrator should be given the option of ReiserFS.

I will probably recompile my kernel with ReiserFS support, but this is a step
back in Linux's attempt to be user-friendly and Red Hat's move into the Desktop
market.
Comment 1 Gerald Teschl 2003-07-26 09:02:05 EDT
reiserfs is part of the kernel-unsupported package.
Comment 2 Justin Churchey 2003-07-26 15:09:23 EDT
kernel-unsupported?  Where is that package at and how do I install it?
Comment 3 Bill Nottingham 2003-07-28 17:01:12 EDT

*** This bug has been marked as a duplicate of 100661 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:57:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.