Bug 100661 - Installation should continue support of ReiserFS
Summary: Installation should continue support of ReiserFS
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: beta3
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
: 100663 100865 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-07-24 03:37 UTC by Justin Churchey
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 16:53:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Churchey 2003-07-24 03:37:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011022
Netscape6/6.2

Description of problem:
I attempted to build reiserfs support in the kernel by using the 

"linux reiserfs" command on the boot prompt of the Installation CD.

However, when going to Disk Druid to manually partition my hard drive, reiserfs
was not an option as a file system.

I believe it is important to continue support of the reiserfs filesystem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Type in "linux reiserfs" at the boot prompt of the linux CD
2.Manually partition in Disk Druid when running anaconda.
3.Try to create or modify a partition
4.Check filesystems available
    

Actual Results:  ReiserFS was not listed.

Expected Results:  ReiserFS should be listed.

Additional info:

Comment 1 Jeremy Katz 2003-07-24 06:58:04 UTC
If it's in the kernel, it will get pulled in.  Else, it doesn't.

Comment 2 Jeremy Katz 2003-07-24 15:25:09 UTC
*** Bug 100663 has been marked as a duplicate of this bug. ***

Comment 3 Justin Churchey 2003-07-24 20:28:23 UTC
Are you saying that your kernel does not have support for reiserfs in this
release? In previous installation programs you have been able to pass reiserfs
as a parameter to the kernel, enabling it.  Why is that not the case here?

Comment 4 Bill Nottingham 2003-07-28 20:14:19 UTC
Because the module isn't built.

Comment 5 Bill Nottingham 2003-07-28 21:01:17 UTC
*** Bug 100865 has been marked as a duplicate of this bug. ***

Comment 6 Michael Young 2003-07-30 10:02:00 UTC
Once the system is installed reiserfs is in the kernel*-unsupported package (a
collection of extra unsupported modules) - pick whichever matches your kernel
and add it. However reiserfs isn't supported at install time because the module
isn't in kernel-BOOT, and there is no equivalent kernel-BOOT-unsupported package
(though it isn't obvious how this would work even if there was).

Comment 7 Justin Churchey 2003-08-02 16:42:46 UTC
Where can one get these kernel*-unsupported packages for installation, and how
do you plan on making the users aware of their option to use ReiserFS?

Comment 8 Ben Russo 2003-09-05 02:41:20 UTC
Reiserfs support would be greatly appreciated.  I use it on mail servers, proxy
servers, rsync backup servers, cvs servers etc... (generally anywhere that I
would  either run out of inodes, or where I would have to wait more than .75
seconds to do an "ls" in a directory.  ReiserFS is GREAT for file systems where
there are lot s and lots of small files.

Comment 9 Dave Jones 2003-10-17 01:57:44 UTC
Kernel is building the module correctly.. Should work these days as long as it's
being modprobe'd by anaconda.

/lib/modules/2.4.22-1.2093.nptl/unsupported/fs/reiserfs:
-rwxr--r--    1 root     root       240868 Oct 14 22:59 reiserfs.o*



Comment 10 Jeremy Katz 2003-10-21 16:53:12 UTC
Yep, should be fine in test3 at least (if not test2 as well) when you boot with
'linux reiserfs'


Note You need to log in before you can comment on or make changes to this bug.