Bug 100866 - ReiserFS should continue to be Supported
Summary: ReiserFS should continue to be Supported
Status: CLOSED DUPLICATE of bug 10865
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: athlon Linux
high
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-26 07:31 UTC by Justin Churchey
Modified: 2007-03-27 04:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-26 19:19:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Churchey 2003-07-26 07:31:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
In previous versions of RH Linux, when it boots off the installation CD you
could pass the "reiserfs" parameter to the linux boot command and the kernel
would be ReiserFS enabled.  I could set mountpoints for the ReiserFS partitions
of my other distros, even share a /home partition b/t all three.

However, ReiserFS is not even an option in your kernel release.  My partitioning
was a hassle b/c of my inability to set mountpoints.  I cannot continue to share
my /home partition or swap files b/t distros b/c RH cannot interact with the
other filesystems.


Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1.Install the RH Kernel with anaconda

    

Actual Results:  Disk Druid is not able to work w/ ReiserFS partitions
Cannot read files in other OS b/c of inability to mount the filesystem.

Expected Results:  RH should continue support of popular filesystems.

Additional info:

ReiserFS is still in wide use by a lot of other *nix systems and linux distros.
 To take away ReiserFS support in your kernel build greatly hampers a users
ability to interact with another popular filesystem.  Linux was meant to be
highly customizable and the administrator should be given the option of ReiserFS.

I will probably recompile my kernel with ReiserFS support, but this is a step
back in Linux's attempt to be user-friendly and Red Hat's move into the Desktop
market.

Comment 1 Justin Churchey 2003-07-26 07:45:30 UTC

*** This bug has been marked as a duplicate of 10865 ***

Comment 2 Justin Churchey 2003-07-26 19:19:52 UTC
Actually it is a duplicate bug of #100865 rather than #10865.  It was just a
typo, just like I hit the submit button more than once.


Note You need to log in before you can comment on or make changes to this bug.