Bug 10865 - Eth0 does not load on bootup
Eth0 does not load on bootup
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
: 100866 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-16 21:37 EDT by compwiz
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 10:47:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description compwiz 2000-04-16 21:37:47 EDT
Using initscripts-5.07-1, and no change in device configuration since
redhat 6.2, I have eth0 set to be enabled on bootup. However, only lo gets
activated, not eth0. Perhaps something screwy in the egrep lines of
/etc/rc.d/init.d/network? I couldn't trace it down myself.
Comment 1 compwiz 2000-04-16 21:50:59 EDT
I figured out what's causing this - seems like a little typo in the logic there. Lines 63 and 65 have to be switched, or else the opposite of the intended action will happen. Also, it seems as though adding the 'grep -v "^#"' to there didn't make a difference with stopping lines that start with # to be ignored, but that's not my problem.
Comment 2 Bill Nottingham 2000-04-17 10:47:59 EDT
Fixed in 5.08 and later. (yes, the grep was in the wrong place.)
Comment 3 Justin Churchey 2003-07-26 03:45:32 EDT
*** Bug 100866 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.