Bug 100869 - (SOUND ICH5) Test Sound crashes system
(SOUND ICH5) Test Sound crashes system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-07-26 08:08 EDT by Marcos F. Villa
Modified: 2013-07-02 22:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 03:03:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcos F. Villa 2003-07-26 08:08:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.5

Description of problem:
I have an intel motherboard (Intel D865-GBF) which has a sound card onboard
(ICH5). The problem is that when you click on test sound at the sound
configuration utility of firstboot the system crashes and it's impossible to
cancel it because even the keyboard dies.

As firstboot says the model is:

Vendor: Intel Corp.
Model: 82801EB AC'97 Audio Controller
Module: i810_audio

I think the process could be skipped and run when firstboot finishes, other way
there should be a text explaining the users that the system could crash because
the driver provided by the kernel may not suppor their sound card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. After installation follow the firstboot sequence
2. In the Sound configuration utility click on test sound
3. If you have the same mother than I have you should be rebooting your pc
    

Actual Results:  The system crashes after clicking on Test Sound

Expected Results:  It's supposed that the system should play 3 sounds, or not if
the driver doesn't suppose that sound board, but instead of doing it the system
crashed

Additional info:
Comment 1 Brent Fox 2003-07-28 12:33:15 EDT
Reassigning to the kernel.
Comment 2 Michael K. Johnson 2003-10-27 12:09:24 EST
We need a few bits of information from your system:
1) The output of "lspci -vxx" (run as root) on this system
2) The oops message produced when the system crashes.

The second is going to be a bit harder to get.  If you have two
systems and a serial cable, you can set up serial console.  Otherwise,
we'll have to get you some alternate instructions to reproduce this at
a text console so that you can copy down the oops information and
provide it to us.  Let us know which is the case.
Comment 3 Marcos F. Villa 2003-10-27 13:03:44 EST
Ok, I'm downloading the latest severn version, to see how it works now,I don't
have the serial cable (but I could do it if you tell me how),the only problem is
that in my network the only machine with Linux is mine and I don't know if the
serial will work ok with other systems.
Comment 4 Michael K. Johnson 2003-10-27 14:05:53 EST
ok, if you can get a null modem serial cable connected between two machines,
here's how to use it:

to your boot line, add to the end:
  console=ttyS0,9600 console=tty0
and on the machine at the other end, capture the serial data with
settings of 9600 bps, no parity, 8 bits -- that's a very common
setting that should work on any system with an application that can
capture serial output.

Note that even the text console will be limited to 9600 bps output,
so it will be a lot slower.
Comment 5 Jeff Garzik 2004-03-03 03:10:38 EST
Does this problem still occur in the latest { RHEL3 | Fedora }?

Note You need to log in before you can comment on or make changes to this bug.