This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1008755 - should block to do live migration when trying to migrate a VHDX image file
should block to do live migration when trying to migrate a VHDX image file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jeff Cody
Virtualization Bugs
: TestOnly
Depends On:
Blocks: 1006159
  Show dependency treegraph
 
Reported: 2013-09-16 22:54 EDT by Sibiao Luo
Modified: 2014-10-14 02:51 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:51:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-09-16 22:54:23 EDT
Description of problem:
when do live migration with used VHDX format disk, QEMU should be blocked to do live migration and give a message prompt that "Block format 'vhdx' used by device 'drive-data-disk' does not support feature 'live migration".
BTW, tried the vpc format that did not have such issue.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm
2.6.32-419.el6.x86_64
qemu-kvm-0.12.1.2-2.402.el6.x86_64
guest info:
2.6.32-419.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.create a VHDX format image via Hyper-V.
# qemu-img info /mnt/sluo-data-disk.vhdx
image: /mnt/sluo-data-disk.vhdx
file format: vhdx
virtual size: 2.0G (2147483648 bytes)
disk size: 388M
2.boot guest with VHDX format disk in src and do some read from the VHDX disk.
e.g:...-drive file=/mnt/sluo-data-disk.vhdx,if=none,id=drive-data-disk,format=vhdx,cache=none,werror=stop,rerror=stop,readonly=on -device virtio-blk-pci,bus=pci.0,addr=0x7,drive=drive-data-disk,id=data-disk
guest] # dd if=/dev/vdb of=/dev/null bs=10k
3.boot a dest with incoming mode.
<same-to-src-cli>-incoming tcp:0:5888,server,nowait
4.migration from src to dest and check it.
- src:
(qemu) migrate -d tcp:0:5888
(qemu) info migrate 
Migration status: active
total time: 2229 milliseconds
transferred ram: 70377 kbytes
remaining ram: 1764016 kbytes
total ram: 2113920 kbytes
...
(qemu) info migrate 
Migration status: completed
total time: 18110 milliseconds
downtime: 31 milliseconds
transferred ram: 598047 kbytes
remaining ram: 52 kbytes
total ram: 2113920 kbytes
(qemu) q

-dest:
(qemu) c
(qemu) info status 
VM status: running

Actual results:
after step 4, it can complete migration from src to dest successfully.

Expected results:
QEMU should be blocked to do live migration and give a message prompt that "Block format 'vhdx' used by device 'drive-data-disk' does not support feature 'live migration".

Additional info:
# /usr/libexec/qemu-kvm -M pc -S -cpu SandyBridge -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -no-kvm-pit-reinjection -usb -device usb-tablet,id=input0 -name sluo -uuid 990ea161-6b67-47b2-b803-19fb01d30d30 -rtc base=localtime,clock=host,driftfix=slew -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=0,bus=pci.0,addr=0x3 -chardev socket,id=channel1,path=/tmp/helloworld1,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port1 -chardev socket,id=channel2,path=/tmp/helloworld2,server,nowait -device virtserialport,chardev=channel2,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port2 -drive file=/mnt/RHEL6.5-20130830.2-Server-x86_64.qcow2,if=none,id=drive-virtio-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,vectors=0,bus=pci.0,addr=0x4,scsi=off,drive=drive-virtio-disk,id=virtio-disk,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=2C:41:38:B6:40:21,bus=pci.0,addr=0x5 -device virtio-balloon-pci,id=ballooning,bus=pci.0,addr=0x6 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -drive file=/mnt/sluo-data-disk.vhdx,if=none,id=drive-data-disk,format=vhdx,cache=none,werror=stop,rerror=stop,readonly=on -device virtio-blk-pci,bus=pci.0,addr=0x7,drive=drive-data-disk,id=data-disk -k en-us -boot menu=on -vnc :1 -monitor stdio
Comment 4 Jeff Cody 2013-11-21 14:10:45 EST
The patch series for BZ 1007176 included the backport of the upstream migration blocker patch for VHDX.
Comment 7 Jeff Cody 2013-11-27 11:04:36 EST
(In reply to Jeff Cody from comment #4)
> The patch series for BZ 1007176 included the backport of the upstream
> migration blocker patch for VHDX.

Sorry, I mistook this for the RHEL7 BZ.  For RHEL6, the migration blocker was not added, as the VHDX image driver only supports r/o currently.
Comment 8 Ademar Reis 2014-06-26 09:53:46 EDT
(In reply to Jeff Cody from comment #7)
> (In reply to Jeff Cody from comment #4)
> > The patch series for BZ 1007176 included the backport of the upstream
> > migration blocker patch for VHDX.
> 
> Sorry, I mistook this for the RHEL7 BZ.  For RHEL6, the migration blocker
> was not added, as the VHDX image driver only supports r/o currently.

Moving it back to ASSIGNED. We'll move it to ON_QA (it's a TestOnly bug) once Bug 1006159 is merged.
Comment 9 Jeff Cody 2014-07-29 14:23:48 EDT
Bug 1006159 is merged, so moving this to ON_QA
Comment 12 Sibiao Luo 2014-08-11 05:10:50 EDT
Verified this issue with the same steps as comment #0 on qemu-kvm-0.12.1.2-2.436.el6.x86_64 which has blocked vhdx format image to do live migration.

host info:
# uname -r && rpm -q qemu-kvm
2.6.32-491.el6.x86_64
qemu-kvm-0.12.1.2-2.436.el6.x86_64

Test results:
e.g.:...-drive file=/mnt/sluo-data-disk.vhdx,if=none,id=drive-data-disk,format=vhdx,cache=none,werror=stop,rerror=stop,readonly=on -device virtio-blk-pci,bus=pci.0,addr=0x7,drive=drive-data-disk,id=data-disk
(qemu) migrate -d tcp:0:5888
Block format 'vhdx' used by device 'drive-data-disk' does not support feature 'live migration'

Best Regards,
sluo
Comment 13 errata-xmlrpc 2014-10-14 02:51:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1490.html

Note You need to log in before you can comment on or make changes to this bug.