Bug 1008784 - Bug: Creating new topic via UI needs a writer
Bug: Creating new topic via UI needs a writer
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.7
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 00:48 EDT by Misha H. Ali
Modified: 2014-06-22 17:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2013-09-17 00:48:23 EDT
Description of problem:

Not sure if this is a bug for the CSP or the UI, but it looks like creating a new topic using the CCMS UI[1] results in an error[2].

The CSP Map in question does not have a writer specified at the highest level because different people create different content and we want those topics to be assigned to the correct writer name.

[1] - Section: Name of Topic [N, Concept]
[2] - ERROR: Line 301: Invalid Topic! Writer name doesn't exist.
       -> Name of Topic [N, Concept]
ERROR: The Content Specification is not valid.

Reported this to lnewson and he said: 

"I know on the backend I made it use the user specified in the request, but the UI always sends the "Unknown" user"
Comment 1 Lee Newson 2013-09-17 01:31:48 EDT
Yeah, the idea was that whoever was saving the content spec would be assigned the topic if no writer was specified. Will have to talk to Matt about we want to resolve this one.

As for the component it is fine as is because this is also a problem in the csprocessor client as well.
Comment 2 Tim Hildred 2013-09-25 01:28:59 EDT
In my opinion, this is not a bug. 

As topic updates require an author, so too should topic creation. Isn't the topic creation really just a revision?

That is why I raised bug:
https://bugzilla.redhat.com/show_bug.cgi?id=989280

I don't think any change to the database should be allowed without attribution to someone.
Comment 3 Misha H. Ali 2013-09-25 01:32:17 EDT
Agreed about no topic should exist without a writer. My intention with this bug was that it should save who I am (as we do with revision histories) and use that value when I use the CCMS UI to create a topic via the UI.
Comment 4 Lee Newson 2014-06-18 20:19:12 EDT
I think that we can safely remove this feature now as the goal for the writer attribute, was to add the appropriate "Writer" tag for that topic. This would then allow us to generate an automated author group.

However now that we have the ability to log that info in the revision history it should ideally be pulled from there. Although that is another issue altogether, as it would first require authentication and various other components. For now though given that it just adds strain to new users and the automated author groups are rarely used I think it should be removed.
Comment 5 Lee Newson 2014-06-18 20:23:24 EDT
Note: I'm not talking about the ability to add a writer tag via the "writer" attribute, but instead that it is a mandatory field for new topics.
Comment 7 Lee Newson 2014-06-18 21:13:17 EDT
Fixed in 1.7-SNAPSHOT build 201406191107

The writer attribute is no longer a mandatory field and the "Unknown" user won't be set as the global "writer" attribute by default when no username is passed.

Note: This version is currently live on the test/development server.
Comment 9 Matthew Casperson 2014-06-18 22:45:15 EDT
Verified that new topics can be created from a content spec through the UI and through csprocessor with and without the writer option.

Note You need to log in before you can comment on or make changes to this bug.