Bug 1008900 - [RHSC] Show error pop-up when user tries to stop a volume which has rebalance in progress
[RHSC] Show error pop-up when user tries to stop a volume which has rebalance...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity unspecified
: ---
: RHGS 2.1.2
Assigned To: Kanagaraj
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 06:09 EDT by Shruti Sampat
Modified: 2016-04-18 06:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: CB3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:38:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19363 None None None Never

  None (edit)
Description Shruti Sampat 2013-09-17 06:09:11 EDT
Description of problem:
-----------------------
When rebalance is running on a volume, and the user tries to stop the volume, the Console displays a message in the events log that says, 

"Could not stop Gluster Volume <vol-name>."

This message does not tell the user the reason for failure to stop the volume. An error pop-up needs to be shown to the user with the reason for failure to stop the volume.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.2.master.20130911113322.gite7ade4a.fc19 

How reproducible:
Observed it a couple of times, at other times, stopping the volume was successful (Bug 1008889)

Steps to Reproduce:
1. Start rebalance on a volume.
2. Try to stop the volume while rebalance is running.

Actual results:
Volume-stop fails with the above described events log message.

Expected results:
An error pop-up which says that stopping the volume is not possible because rebalance is in progress, should be shown to the user.

Additional info:
Comment 2 Scott Haines 2013-09-23 19:34:57 EDT
Targeting for 2.1.z U2 (Corbett) release.
Comment 3 Shruti Sampat 2013-10-18 09:00:17 EDT
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.0.scratch.beta1.el6_4. 


The error pop-up says that the gluster volume cannot be stopped as rebalance is running on the volume.
Comment 5 errata-xmlrpc 2014-02-25 02:38:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.